HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Ftp Passwords not working (http://www.howtoforge.com/forums/showthread.php?t=58348)

fireshard 22nd August 2012 22:09

Ftp Passwords not working
 
Hello,

I've recently installed ISPConfig 3.0.4.6 on an Ubuntu virtual server and it says that all services are working in the monitor tab of ISPConfig, but when I created an ftp account and tried to logon with Filezilla, it told me the password was incorrect and I check if it was the wrong password, but it is not, does anyone know how to fix this issue ?

Thank you in advance.

Text from Filezilla, with hostname and IP removed.
Status: Resolving address of hostname.domain.tld
Status: Connecting to *.*.*.*:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 20:39. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER creatures_wsftp
Response: 331 User creatures_wsftp OK. Password required
Command: PASS ********
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

yuro 22nd August 2012 23:25

I'm having the same problem as well. Same scenario too. Ubuntu VM, fresh install.

Croydon 23rd August 2012 09:12

Please have a look in the server logs (ftp-server log, syslog, auth.log) if there are any messages during login try.

yuro 25th August 2012 00:03

from /var/log/auth.log
 
Here's what seems to be the issue. Seems Jailkit is the problem, but not sure what to do.

from /var/log/auth.log
Code:

Aug 24 14:55:30 server1 sshd[3760]: Accepted password for [client_user] from 192.168.0.24 port 53909 ssh2
Aug 24 14:55:30 server1 sshd[3760]: pam_unix(sshd:session): session opened for user [client_user] by (uid=0)
Aug 24 14:55:31 server1 sshd[3878]: subsystem request for sftp by user [client_user]
Aug 24 14:55:31 server1 jk_chrootsh[3879]: now entering jail /var/www/clients/client1/web1 for user [client_user] (5004) with arguments -c /usr/lib/openssh/sftp-server
Aug 24 14:55:31 server1 sshd[3760]: pam_unix(sshd:session): session closed for user [client_user]


yuro 25th August 2012 04:22

Fixed. Was a problem with Jailkit.

Found the solution in the developers forum:
http://www.howtoforge.com/forums/sho...4&postcount=12

I can now use SFTP with Coda for my sites with jailkit securely.


All times are GMT +2. The time now is 10:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.