HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   phpvirtualbox tutorial - problem (http://www.howtoforge.com/forums/showthread.php?t=58297)

mcc28x 17th August 2012 15:02

phpvirtualbox tutorial - problem
 
Hi,

I have followed the tutorial http://www.howtoforge.com/managing-a...x-ubuntu-12.04 but have an error when I try to login at myserver/phpvirtualbox/

I use the default username/password (admin/admin) but ge tthe following error message:

Code:

Exception Object
(
    [message:protected] => Error logging in to vboxwebsrv.
    [string:Exception:private] =>
    [code:protected] => 64
    [file:protected] => /var/www/phpvirtualbox/lib/vboxconnector.php
    [line:protected] => 188
    [trace:Exception:private] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/phpvirtualbox/lib/auth/Builtin.php
                    [line] => 45
                    [function] => connect
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

            [1] => Array
                (
                    [file] => /var/www/phpvirtualbox/lib/ajax.php
                    [line] => 119
                    [function] => login
                    [class] => phpvbAuthBuiltin
                    [type] => ->
                    [args] => Array
                        (
                            [0] => admin
                            [1] => admin
                        )

                )

        )

    [previous:Exception:private] =>
)

The only information in the logfile is:
Code:

VirtualBox web service 4.1.18 r78361 linux.amd64 (Jun 20 2012 14:50:49) release log
00:00:00.000 main    Log opened 2012-08-17T12:52:51.706645000Z
00:00:00.000 main    OS Product: Linux
00:00:00.000 main    OS Release: 3.2.0-29-generic
00:00:00.000 main    OS Version: #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012
00:00:00.000 main    OS Service Pack: #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012
00:00:00.000 main    Executable: /usr/lib/virtualbox/vboxwebsrv
00:00:00.000 main    Process ID: 3993
00:00:00.000 main    Package type: LINUX_64BITS_UBUNTU_12_04
/var/log/vboxweb.log (END)

There are some threads on the web about this error but none of them particularly conclusive. Anyone help me resolve this please?

regards

Mark

mcc28x 17th August 2012 20:52

I solved this by logging in as user vbox and issuing
Code:

VBoxManage setproperty websrvauthlibrary null


All times are GMT +2. The time now is 06:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.