HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Httpd service not starting (http://www.howtoforge.com/forums/showthread.php?t=58287)

louder_than_loud 16th August 2012 13:38

Httpd service not starting
 
Hi Everyone,

A little background on my problem:
We have a webserver running with centOS 4.7 and apache 2.2. It runs several virtual hosts, and was set up by a former colleague. Apache is installed in a mounted drive called /wwwroot

This webserver has now fallen under my control, and although I have some knowledge of linux systems, I'm still quite a newbie. The server has been running happily for months, but now the need has come up for me to add a new website to the server.

Now the problem:

I made a change to the httpd.conf file adding a new virtual host, a duplicate of the 6 other servers in the file (obviously changing the paths and servername), saved the file and restarted the httpd service. But the httpd service didn't restart, it fails claiming it can't find the httpd.conf file in the default location (/etc/httpd/), which is right, because the file isn't there and looks like it never has been, and I wouldn't expect it to be as Apache is installed in /wwwroot.
Hence my question, why is it suddenly looking there for the file? In the last week of messing about I've even come to realise that the conf file I changed may well not have even been the live file (he seems to have at least a dozen different versions of the file scattered over /wwwroot and /root folders). But either way I didn't change any paths to config files so I don't understand why it is now looking for files that have never been there.

I just tried running httpd -f /wwwroot/apache/conf/httpd.conf to force it to use that file and I get:

Syntax error on line 54 of /wwwroot/apache/conf/httpd.conf:
API module structure `authn_file_module' in file /wwwroot/apache/modules/mod_authn_file.so is garbled - perhaps this is not an Apache module DSO?


I tried running the make install (using the same config I presume he used) again, but still same problem.

Any ideas how to make this work now?

I know it's difficult without knowing the exact setup, but any help would be appreciated. I've enjoyed tinkering with it, but I'm pulliing my hair out and people are now nagging for some of these web services to be back online, so could do with sorting asap.

Thanks

falko 18th August 2012 00:17

Sounds to me as if there are two Apache's installed, and you tried to restart the wrong one. Try to find out where the second Apache's httpd binary and init script are located.


All times are GMT +2. The time now is 10:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.