HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   need some nginx help (http://www.howtoforge.com/forums/showthread.php?t=58232)

joey3002 10th August 2012 20:06

need some nginx help
 
I need some help.
I used this to build my server:
http://www.howtoforge.com/perfect-se...ispconfig-3-p4

I am working on a php app on a dedicated server. It has a bunch of check boxes and when I click them, it sends an email with the info.

If I check 15, all is good. However, I am trying to ramp it up and check 150.
I get an error 500 - Internal server error

However, when I look at:

/var/log/ispconfig/httpd/mysite.com/error.log

there is nothing reported. Where can I find more info out about this? I am trying to allow for more processes to run without timing out.

thanks in advance

joey3002 11th August 2012 00:14

this is what I get:

504 Gateway Time-out

nginx/1.1.19

joey3002 11th August 2012 00:18

and more info:


2012/08/11 00:12:41 [error] 2035#0: *2070 upstream timed out (110: Connection timed out) while reading response header from upstream, client: MYIP, server: mysite.com, request: "POST /clients/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9010", host: "www.mysite.com", referrer: "http://www.mysite.com/clients/?a=3"

joey3002 11th August 2012 00:31

issue fixed

I was in the wrong vhost section.. i need to add it to the vhost for my domain

nginx terminated the connection to php-fpm after 60s because

fastcgi_send_timeout 300s;
fastcgi_read_timeout 300s;

were missing.

onastvar 15th February 2013 17:11

I have same issue, could you please share your vhost (nginx directives)?


All times are GMT +2. The time now is 03:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.