HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   403 Forbidden error in ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=58216)

dublekay 8th August 2012 23:26

403 Forbidden error in ISPConfig 3
 
Hi Guys

I've been using ISPConfig on several servers for a while now without issue.

I have jsut installed it (twice) on a customers VPS running in an OpenVZ container (Solus VM system) and when I try to access the ISPCOnfig interface on port 8080 I get a

Forbidden

You don't have permission to access / on this server.

error.

The OS is Debian 6, and im using Apache2 as the web server.

All the permissions look exactly the same as other installations, so im *guessing* it has some weird issue with SETUID permissions because of OpenVZ or something?

Does anyone have any pointers as to where I can look? There is nothing useful in the apache error logs either, just a repetition of the error displayed in the browser.

Thanks for any assistance!

Mike

till 9th August 2012 08:00

Openvz should not cause any problems. Plesae take a look at the apache error.log file if there is a more verbose error message.

dublekay 9th August 2012 22:43

Quote:

Originally Posted by till (Post 283461)
Openvz should not cause any problems. Plesae take a look at the apache error.log file if there is a more verbose error message.

Hi Till,

Thanks for the reply.

The apache logs show nothing of any use.

[Fri Aug 10 00:40:54 2012] [error] [client xxx.xxx.xxx.xxx] (13)Permission denied: access to / denied

I've used ISPConfig 3 on so many servers without hassle, and this one has me beat right now.

dublekay 10th August 2012 04:54

UPDATE: Solved. The VPS Master was storing its containers in a NFS share that was messing with the permissions.

Remounted the same location using iSCSI and all is now good.

DiMoNd 26th February 2013 09:06

Permission, ssh problems
 
Hi.

I have just installed a debian server with ispconfig following this guide: "The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]" and everything works ok but two things..

i) When I log into ispconfig panel under a user account, I create and add a website I then get "Forbidden
You don't have permission to access /xxxxxxxxx.com on this server."

This happens with every single website I add on my server. The only way I can fix this is go into "/etc/apache2/sites-enabled/100-xxxxxxxxx.com.vhost" and change the "<Directory /var/www/xxxxxxxx.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>"

to "<Directory /var/www/xxxxxxxxx.com>
AllowOverride None
Order Deny,Allow
Allow from all
</Directory>"

Only then I can see the website.

ii) When I add a ssh user(on ispconfig) I want this user to NOT be able to go to "/etc/..." .


Thank you!

till 26th February 2013 09:34

1) How did you try to access the site? Sites can be accessed by domain name only or by IP address if a site has a dedicated IP. What does not work is something like http://192.168.0.10/mydomain.com/web/

2) Enable chrooting in the client settings. And donz mix up the /etc directory that you see as chrooted user with the /etc directory of the server, these are not the same!

DiMoNd 26th February 2013 09:50

1) I do not have a domain name configured yet. I use a public IP address but the server gets an internal IP address (192.168.1.4) with ports 80, 22 etc. forwarded. So when I write http://192.168.0.10/mydomain.com/web/ or http://213.xxx.xxx.xxx/mydomain.com/web/ I get the 403 error.

2) I guess then everything is ok with chrooting. You are right, it is not the same /etc directory as server's.

till 26th February 2013 10:01

Ok, so the system is working correctly. You can not access sites like this. Enter the domain name of the site in the browser to access the site. If the domain does not exist, use this:

http://www.faqforge.com/linux/contro...-a-dns-record/

DiMoNd 26th February 2013 10:22

Yeah!!!
 
Thanks a lot!

Now everything is working perfect!


All times are GMT +2. The time now is 16:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.