HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   amavis - "clamd.sock: No such file or directory" (http://www.howtoforge.com/forums/showthread.php?t=58080)

awado 25th July 2012 21:58

amavis - "clamd.sock: No such file or directory"
 
Hello world!

For the last 12 hours I was digging deep into Google results to get a tricky bug out of my freshly installed ISPC on Centos 6: amavis always reported a fatal error when trying to scan an incoming mail.

amavis[4260]: (04260-02) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/spool/amavisd/clamd.sock (Can't connect to UNIX socket /var/spool/amavisd/clamd.sock: No such file or directory) at (eval 90) line 373.\n

It seems to be a problem for a lot of people. Several Google results advised to change the path so clamd.sock in the amavisd.conf and clamd.conf. But nothing helped. But as the spool folder is only a temporary folder, its content must be created somehow at the startup of some service. That pointed me to the right direction:

chkconfig clamd.amavisd on

It starts clamd for amavisd at boot time and therefore creates the clamd.sock, so it can be accessed. Maybe it saves someone else's day...


All times are GMT +2. The time now is 23:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.