HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   suphp not working (http://www.howtoforge.com/forums/showthread.php?t=58022)

Anand_47 21st July 2012 17:29

suphp not working
 
I am trying to compile lamp server with suphp. I installed all of it and i am getting php info page with normal apache handler but when i try to use suphp i am getting errors with libmysqlclient.so.18 cannot open shared object no such file or directory i am using mysql 5.5 php 5.4 and apache 2.2 . I installed sql server in /sql directory .i can see /sql/lib/libmysqlclient.so.18.0.0 .But why it is not working :( .Anyone please help me out thanx :)
:confused:

TiTex 21st July 2012 18:18

probably can't find the lib because it's not in the standard location like /lib/ or /usr/lib/
you should create a symlink for the library in one of this dirs usally /usr/lib/ or /usr/lib/mysql/

Code:

for file in $(ls /sql/lib/ | grep libmysqlclient.so); do ln -s /sql/lib/$file /usr/lib/$file; done

Anand_47 22nd July 2012 15:41

suphp
 
1 Attachment(s)
I did the same thing but its not working i created symbolic links to /usr/lib/mysql
in the directory libmysqlclient.so.16 and some other files present .But still I am getting errors..Check my error log screen shots Thanks for quick replay.. :) :confused:

TiTex 22nd July 2012 15:58

what linux distribution are you using ?
is it a 32bit or 64bit distribution ?
can you also post the link for the howto you followed ?
also what is the output of ls -l /usr/lib/ | grep libmysqlclient.so && ls -l /usr/lib/mysql

Anand_47 23rd July 2012 11:07

suphp
 
2 Attachment(s)
Yes here it is i am using cenos 6 32-bit edition i listed /usr/lib but i didnt get any output probably nothing in there here m posting my /usr/lib/mysql and /sql/lib directory thanks for your posts bro.. :)

TiTex 23rd July 2012 11:15

run these commands as i posted them one by one, just copy/paste in a ssh terminal
Code:

rm -f /usr/lib/mysql/libmysqlclient.so
rm -f /usr/lib/mysql/libmysqlclient.so.18
rm -f /usr/lib/mysql/libmysqlclient.so.18.0.0
for file in $(ls /sql/lib/ | grep libmysqlclient.so); do ln -s /sql/lib/$file /usr/lib/mysql/$file; done

and try again after that , if still not working post again the content of
Code:

ls -l /usr/lib/mysql

Anand_47 24th July 2012 10:43

suphp not working
 
I am still getting same error i think my os damaged have to reinstall or something
i was getting same error when i try to install fastcgi also.linux sometimes so hard like this unknown things sorry for my bad english thanks for your support
:)


All times are GMT +2. The time now is 02:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.