HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Remote API Problem (http://www.howtoforge.com/forums/showthread.php?t=58020)

djmostek 21st July 2012 13:29

Remote API Problem
 
It's me again :)
I've made use of remote API that is enclosed with new ISPConfig and made use of its documentation and made script which makes auttomatically accounts. It makes: site, ftp and mysql database. The problem is that when i logg into ftp account made by remote API I see nothing at all - it's empty BUT the dafault page ('This is the default index page of your website.') displays which suggest that his ftp account is not empty.

I must admit that when I create ftp account in panel directly I see all the catalogues after ftp login...

Any suggestions how to solve this problem?

PS. In my scrip config I made a dir where ftp accounts are created like this: /var/www/clients/client%USERID%/web%WEBDOMAINID%/web/

till 23rd July 2012 08:55

Compare the database record in the ftp_user table of a account created with the api with a account that you created in the ispconfig interface and then adjust your api parameters that the account created by the api uses the correct paths and user names like the one created by the interface.

djmostek 23rd July 2012 14:45

There's a difference in table ftp_user:

for that one created by panel the fileds uid and gid looks like this:
Code:

uid= web8
guid= client10

for that one created by API using my script:
Code:

uid=5000
guid=5000

while the 'dir' is the same for both.

till 23rd July 2012 14:47

Modify your script so that you insert the correct user and group name of this website instaed of the numbers 5000.

djmostek 23rd July 2012 23:22

Quote:

Originally Posted by till (Post 282586)
Modify your script so that you insert the correct user and group name of this website instaed of the numbers 5000.

Yes, I've changed this and everything works fine ;-) I've serached into databse but not simply in ftp_user... :) thank u


All times are GMT +2. The time now is 04:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.