HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig uses Localhost settings, VHosts instead through Apache Directive (http://www.howtoforge.com/forums/showthread.php?t=57951)

Nap 16th July 2012 15:11

ISPConfig uses Localhost settings, VHosts instead through Apache Directive
 
Hi,
I'm trying to make the ISPConfig page available to my clients via their own domain name. So far I've been able to do it, but not as elegantly as I would like.

If they use the correct url, https://mydomain:ISPConfig_Port, it works fine. However, if they forget to enter the 's' and type http://mydomain:ISPConfig_Port Apache returns an error. Which is exactly what I want. (Not looking for a redirect here. They just gotta get it right.)

However, in the error page, I get references to webmaster@localhost (as ServerAdmin) and the hostname.domain.int (ServerName) as links within the error message.

After investigation, I realised there is only one virtualhost entry for the ISPConfig in sites-enabled, and though the various domain names I'm hosting all work (they point to the same machine) the daemon is owned by the localhost. Hence my clients see the localhost address instead of their own.

I am thinking that I could change that behaviour by putting a virtualhost entry into the Apache Directives for ISPConfig in each of the client's domain options page and setting the server parameters this way.

Has anyone done this in their install?

For the moment, I'm just going to change the error messages to not mention emails and domains.

Cheers,
Nap

till 17th July 2012 09:29

You are mixing up port based and namebased vhosts here. The ispconfig vhost is a port based vhost and not a namebesed vhost, for a port based vhost, there exists only one for all domains and not one for every domain. The port based vhost uses the fqdn server name (and not localhost) as hostname. If your server sues localhost, then you entered a wrong hostname during server installation.


All times are GMT +2. The time now is 19:06.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.