HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Horde 4 added to a running ISPConfig System (http://www.howtoforge.com/forums/showthread.php?t=57730)

sjswarts 25th June 2012 15:10

Horde 4 added to a running ISPConfig System
 
G'day guys,

I have successfully setup a fresh ISPConfig Debian 6 server and then installed Horde 4 Groupware following Stephen's guide:

http://www.xhhost.com/linux/Install_...PEAR_2991.html

http://www.howtoforge.com/install-ho...e-through-pear

Anyway that works and I'm happy but on my production server I can't get it to install properly this is the errors it shows!!


Code:

root@mail:~# pear install -a -B horde/webmail
Failed to download pear/SOAP within preferred state "stable", latest release is version 0.13.0, stability "beta", use "channel://pear.php.net/SOAP-0.13.0" to install
Failed to download pear/Date_Holidays within preferred state "stable", latest release is version 0.21.6, stability "alpha", use "channel://pear.php.net/Date_Holidays-0.21.6" to install
Failed to download pear/Text_CAPTCHA within preferred state "stable", latest release is version 0.4.3, stability "alpha", use "channel://pear.php.net/Text_CAPTCHA-0.4.3" to install
Failed to download pecl/idn within preferred state "stable", latest release is version 0.2.0, stability "beta", use "channel://pecl.php.net/idn-0.2.0" to install
WARNING: "pear/DB" is deprecated in favor of "pear/MDB2"
Unknown remote channel: pear.phpunit.de
WARNING: "pear/HTTP_Request" is deprecated in favor of "pear/HTTP_Request2"
horde/horde can optionally use package "pear/SOAP"
horde/kronolith can optionally use package "pear/Date_Holidays" (version >= 0.21.0)
horde/Horde_Core can optionally use package "pear/Text_CAPTCHA"
horde/Horde_Mime can optionally use package "pecl/idn"
horde/Horde_Mail requires package "pear/Net_SMTP" (version >= 1.6.0), installed version is 1.4.2
horde/imp requires package "horde/Horde_Mail" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/webmail requires package "horde/imp" (version >= 5.0.21, version <= 6.0.0, excluded versions: 6.0.0)
horde/kronolith requires package "horde/Horde_Mail" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/turba requires package "horde/Horde_Mail" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Mime requires package "horde/Horde_Mail" (version >= 1.1.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/horde requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/ingo requires package "horde/horde" (version >= 4.0.0, version <= 5.0.0, excluded versions: 5.0.0)
horde/ingo requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/mnemo requires package "horde/horde" (version >= 4.0.0, version <= 5.0.0, excluded versions: 5.0.0)
horde/nag requires package "horde/horde" (version >= 4.0.0, version <= 5.0.0, excluded versions: 5.0.0)
horde/nag requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Core requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/content requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/timeobjects requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Form requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Form requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Prefs requires package "horde/Horde_Mime" (version >= 1.5.1, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Rpc requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_DataTree requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Crypt requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Editor requires package "horde/Horde_Core" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Icalendar requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_SyncMl requires package "horde/Horde_Icalendar" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Imap_Client requires package "horde/Horde_Mail" (version >= 1.1.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Imap_Client requires package "horde/Horde_Mime" (version >= 1.4.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Itip requires package "horde/Horde_Icalendar" (version >= 1.0.0beta1, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Itip requires package "horde/Horde_Mime" (version >= 1.0.0beta1, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Mime_Viewer requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Data requires package "horde/Horde_Icalendar" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Data requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Test requires package "channel://pear.phpunit.de/PHPUnit" (version >= 3.5.0)
horde/Horde_Kolab_Storage requires package "horde/Horde_Mime" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)
horde/Horde_Kolab_Storage can optionally use package "horde/Horde_Imap_Client" (version >= 1.0.0, version <= 2.0.0, excluded versions: 2.0.0)

Cheers in advance :p

Steve


All times are GMT +2. The time now is 23:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.