HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Clam Anti Virus Hourly Updates (http://www.howtoforge.com/forums/showthread.php?t=57634)

rkperumala 15th June 2012 13:19

Clam Anti Virus Hourly Updates
 
Hey,

I've recently moved to Clam Anti Virus (0.97.4). I've disabled database check in freshclam.conf but when i see the log (freshclam.log) i see its getting updated hourly.

Please check the log below.


Fri Jun 15 04:05:50 2012 -> --------------------------------------
Fri Jun 15 05:05:50 2012 -> Received signal: wake up
Fri Jun 15 05:05:50 2012 -> ClamAV update process started at Fri Jun 15 05:05:50 2012
Fri Jun 15 05:05:50 2012 -> WARNING: Your ClamAV installation is OUTDATED!
Fri Jun 15 05:05:50 2012 -> WARNING: Local version: 0.97.4 Recommended version: 0.97.5
Fri Jun 15 05:05:50 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
Fri Jun 15 05:05:50 2012 -> main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
Fri Jun 15 05:05:50 2012 -> daily.cld is up to date (version: 15046, sigs: 218172, f-level: 63, builder: jesler)
Fri Jun 15 05:05:50 2012 -> bytecode.cvd is up to date (version: 185, sigs: 39, f-level: 63, builder: neo)
Fri Jun 15 05:05:52 2012 -> --------------------------------------
Fri Jun 15 06:05:52 2012 -> Received signal: wake up
Fri Jun 15 06:05:52 2012 -> ClamAV update process started at Fri Jun 15 06:05:52 2012
Fri Jun 15 06:05:52 2012 -> WARNING: Your ClamAV installation is OUTDATED!
Fri Jun 15 06:05:52 2012 -> WARNING: Local version: 0.97.4 Recommended version: 0.97.5
Fri Jun 15 06:05:52 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
Fri Jun 15 06:05:52 2012 -> main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
Fri Jun 15 06:05:52 2012 -> daily.cld is up to date (version: 15046, sigs: 218172, f-level: 63, builder: jesler)
Fri Jun 15 06:05:52 2012 -> bytecode.cvd is up to date (version: 185, sigs: 39, f-level: 63, builder: neo)
Fri Jun 15 06:05:53 2012 -> --------------------------------------
Fri Jun 15 07:05:53 2012 -> Received signal: wake up
Fri Jun 15 07:05:53 2012 -> ClamAV update process started at Fri Jun 15 07:05:53 2012
Fri Jun 15 07:05:53 2012 -> main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
Fri Jun 15 07:05:54 2012 -> Downloading daily-15047.cdiff [100%]
Fri Jun 15 07:05:54 2012 -> daily.cld updated (version: 15047, sigs: 218173, f-level: 63, builder: edwin)
Fri Jun 15 07:05:54 2012 -> bytecode.cvd is up to date (version: 185, sigs: 39, f-level: 63, builder: neo)
Fri Jun 15 07:05:55 2012 -> Database updated (1262599 signatures) from database.clamav.net (IP: 69.163.100.14)
Fri Jun 15 07:05:55 2012 -> Clamd successfully notified about the update.
Fri Jun 15 07:05:55 2012 -> --------------------------------------


Is this a bug or tuning in conf files at my end fixes this. I want the database to be updated every week, which i have done using a Cronjob.

Appreciate your time...

Thanks
RK

falko 16th June 2012 15:24

Do you have a freshclam cron job in /etc/cron.hourly/?

rkperumala 17th June 2012 08:21

Hello Falko,

Thanks for your quick reply. I don't see any cronjob set as you said. here is the list of cronjobs.


ls /etc/cron*
/etc/cron.allow /etc/cron.deny /etc/crontab

/etc/cron.d:
ntpd rhn-virtualization.cron sysstat

/etc/cron.daily:
0anacron 0logwatch cups logrotate makewhatis.cron mlocate.cron prelink rpm tmpwatch

/etc/cron.fivem:
agentupper

/etc/cron.hourly:
mcelog.cron

/etc/cron.monthly:
0anacron

/etc/cron.weekly:
0anacron 99-raid-check makewhatis.cron


Thanks
RK

rkperumala 18th June 2012 08:03

ClamAV Database updates
 
Quote:

Originally Posted by rkperumala (Post 280735)
Hello Falko,

Thanks for your quick reply. I don't see any cronjob set as you said. here is the list of cronjobs.


ls /etc/cron*
/etc/cron.allow /etc/cron.deny /etc/crontab

/etc/cron.d:
ntpd rhn-virtualization.cron sysstat

/etc/cron.daily:
0anacron 0logwatch cups logrotate makewhatis.cron mlocate.cron prelink rpm tmpwatch

/etc/cron.fivem:
agentupper

/etc/cron.hourly:
mcelog.cron

/etc/cron.monthly:
0anacron

/etc/cron.weekly:
0anacron 99-raid-check makewhatis.cron


Thanks
RK

I've also disabled database checks in freshclam.conf too

falko 19th June 2012 23:33

Can you post your freshclam.conf?


All times are GMT +2. The time now is 23:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.