HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Default page for https (http://www.howtoforge.com/forums/showthread.php?t=57618)

Whistler 13th June 2012 13:49

Default page for https
 
Where can I configure the default page for "https" connection?
For default "http" connection apache correctly points to /var/www/index.html, but for https://server_IP it points to one of the existed "https:// sites.
Please help :)

I'm using ISPConfig 3.0.4.5

falko 14th June 2012 16:26

Try this (if you use Debian/Ubuntu):

Code:

a2ensite default-ssl
Restart Apache afterwards:
Code:

/etc/init.d/apache2 restart

Whistler 14th June 2012 16:48

Thanx for reply, but didn't help.

There is appeared a new file "default-ssl" in /etc/apache2/sites-enabled/ with default path to /var/www/ but still https://Server_IP point to one of the existed "https" sites.

till 14th June 2012 16:57

SSL is a IP based protocol, so you should not have more then one ssl sites on that IP address. The default ssl page is only displayed for IP addresses were no site exists for.

Whistler 14th June 2012 17:26

Strange, but if I type http://Server_IP, apache shows the default page not existed site, but why it's not applicable to https ?


All times are GMT +2. The time now is 07:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.