HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Problem with Network configuration on UBUNTU Server 12.04 LTS (http://www.howtoforge.com/forums/showthread.php?t=57579)

MikeFF 8th June 2012 18:39

Problem with Network configuration on UBUNTU Server 12.04 LTS
 
Hello.

I hope i can find some help about this issue.

Recently I installed my servfer with ubuntu server 12.04 LTS, just console mode, no desktop.

after I end the installation, i wanted to configure multiple sites ins this server, (just I have it on debian 5) for each site one IP.

I did the configuration on /etc/network/interfaces (as ussual), but I put a virtual network, and when I reboot my PC, in the boot comes a message:
"Waiting for server network configuration..."

After a while, comes a new message:

"Waiting up to 60 more seconds for network configuration..."

and it takes about 3 more minutes to boot, after a time, it comes a new message:

"Booting system without full network configuration..."

This is my /etc/netwrok/interfaces file as end of the installation.

Quote:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

auto eth0

iface eth0 inet static
address 192.168.50.2
netmask 255.255.255.0
network 192.168.50.0
broadcast 192.168.50.255
gateway 192.168.50.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.50.2
dns-search mtm.net
Whit that configuration I don't have any problems, everything goes well.

But when I change to this.

Quote:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

auto eth0

iface eth0 inet static
address 192.168.50.2
netmask 255.255.255.0
network 192.168.50.0
broadcast 192.168.50.255
gateway 192.168.50.1
# dns-* options are implemented by the resolvconf package, if installed
#dns-nameservers 192.168.50.2
#dns-search mtm.net

auto eth0:0

iface eth0:0 inet static
address 192.168.50.3
netmask 255.255.255.0
network 192.168.50.0
broadcast 192.168.50.255
gateway 192.168.50.1

auto eth0:1

iface eth0:1 inet static
address 192.168.50.10
netmask 255.255.255.0
network 192.168.50.0
broadcast 192.168.50.255
gateway 192.168.50.1
There is the problem, i have more time to boot.

And one more thing, this server is behind a router, so to to updates, or new installation, I need to add a new nameserver.

I mean, I need to DNS address, one the server it self, and then the primary router to connect to internet.

Could somebody help me with this

Thanks in advance.

falko 9th June 2012 10:45

What happens if you don't comment out the dns-nameservers line?

MikeFF 12th June 2012 21:18

Quote:

Originally Posted by falko (Post 280464)
What happens if you don't comment out the dns-nameservers line?

If I quit the comment, it's exactly the same error, nothing changes.
Everything goes the same way.

I also put the DNS nameserver in the resolv.conf file, but nothing.

falko 13th June 2012 14:36

Can you leave out the network and broadcast lines for the virtual network interfaces (eth0:0 and eth0:1)?

MikeFF 14th June 2012 19:40

Quote:

Originally Posted by falko (Post 280618)
Can you leave out the network and broadcast lines for the virtual network interfaces (eth0:0 and eth0:1)?

Hello falko.

I did what you asked.....

Everything is the same, nothing changes, that messages are invisible only when i remove the virtual network interfaces, as soon as i put one in there, the message comes out.

The rare thing is everything works fine after the server completes the booting process, the problem is that i have to wait at least 3 or more minutes more than the normal time to boot up the server.

Thanks for the help

falko 15th June 2012 13:05

Strange... Could it maybe have anything to do with the NIC? Do you have a spare NIC that you can test with?

TiTex 16th June 2012 10:26

I made the same mistake as you a few years ago and helped me looking at startup logs i saw that whenever you use IP alliases you don't have to specify , infact you should not specify a gateway for your aliases since they are in the same network as the main IP and they will use the same gateway as the main IP, aslo you don't need to specify the network or/and broadcast address , this informations will be inherited from the main IP

in one of your startup logs you should see something like "RTNETLINK answers: File exists" , that File exists actually means that the route (the gateway) already exists in the routing table

so your interfaces file shoud look something like this
Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

auto eth0

iface eth0 inet static
address 192.168.50.2
netmask 255.255.255.0
network 192.168.50.0
broadcast 192.168.50.255
gateway 192.168.50.1
# dns-* options are implemented by the resolvconf package, if installed
#dns-nameservers 192.168.50.2
#dns-search mtm.net

auto eth0:0

iface eth0:0 inet static
address 192.168.50.3
netmask 255.255.255.0

auto eth0:1

iface eth0:1 inet static
address 192.168.50.10
netmask 255.255.255.0

and don't forget to edit /etc/resolv.conf and add your nameservers
test it and let us know if all it's good


All times are GMT +2. The time now is 15:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.