HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Installed 2.2.5 but lost content in ISPconfig (http://www.howtoforge.com/forums/showthread.php?t=5753)

comedit 24th July 2006 13:44

Installed 2.2.5 but lost content in ISPconfig
 
I was installing 2.2.5 over my 2.2.3 Ispconfig installation and just typing my passphrase.

I made a typo at the verification of this passphrase and I asumed that if i just gave an enter, the install script would ask me to retype the the original and verification one again.

Instead it aborted the installscript and gave an error.

I thought not to worry and started reinstalling 2.2.5 but found out that at the end of the script It was installing a brand new installation whitout keeping my data.

My sites still work (which is good) but I can't handle/administer these sites through ISPconfig anymore.

It there a apossibility to incorperate the "I assume lost" data again ? in the 2.2.5 installation ?

Thanks in advance for any bright ideas.

And yes : How could I be so stupid not to make a backup of my data before doing the install !!!

falko 25th July 2006 13:59

Please check in /tmp if there's a backup of /root/ispconfig, /home/admispconfig, and (most important!) the ISPConfig database (the file name is something like existing_db...sql).

comedit 25th July 2006 16:43

Thanks Falko: Yes they are all there
 
They date from 24-05-06 but that's better then nothing.

I will first try to find in the forums/manuals how to get this info back online again before asking any further questions.


Thanks for helping me with this sofar

falko 26th July 2006 10:16

Remove /root/ispconfig and /home/admispconfig. Then untar both tar.gz files and move the files back in place. Restore your ISPConfig database from the sql dump like this: http://www.howtoforge.com/faq/6_4_en.html

comedit 1st August 2006 11:18

Stuck at SQL: #1062 - Duplicate entry '2' for key 1
 
gettind smarter by the minute I have decided to set up a second server and then install rsync to avoid problems as mentioned above:

So i did the perfect setup debian 3.1, installed 2.2.5
(allthough the manual is great, you feel a big relief and satisfaction when its working).

I have replace the /root/ispconfig and /home/admispconfig on the new server and then tried the sql dump (first on commandline then PHPadmin:

This is what I don't understand what is wrong here ?

SQL-query:

INSERT INTO `dns_a` ( `doc_id` , `doctype_id` , `host` , `ip_adresse` )
VALUES ( 2, 1018, 'kigaro', '81.58.147.208' )

MySQL retourneerde: Documentatie
#1062 - Duplicate entry '2' for key 1

:confused:

Since it says duplicate entry I deleted the second one is this list 3,1018,'www','81.58.147.208' .

But that's just trial and error and basically not right

Any suggestions ?

falko 2nd August 2006 13:16

Empty the existing tables before you insert anything.

comedit 2nd August 2006 14:02

That worked but now I can't login anymore
 
Thanks again falko;

That worked, all info is in the tables:

But now I can't login anymore: both the old pasword an the new one don't work for admin.

I made a copy of the database before emptying it.

Is there a way around this issue ?

Thanks in advance

till 3rd August 2006 09:40

Please check that the username and password in the ispconfig config.inc.php file are correct for your mysql database.

comedit 3rd August 2006 10:48

Solved
 
There was no problem getting in to mysql but in to ispconfig itself.

Somehow the password was not working allthough it was identical in the database as where it was copied from.

I have solved it now by copying the code of the password of another user to the admin account in the sys_user table.

It worked, i can log in again and the I have go some of my information back.

Thanks guys for the help and the ofcourse the software itself

PS
I might need to at that this password was identical that I used in the passed for admin


All times are GMT +2. The time now is 17:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.