HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Problems with billing module (http://www.howtoforge.com/forums/showthread.php?t=57522)

mg83264 4th June 2012 14:09

Problems with billing module
 
Hello,

I've just started using ISPconfig 3 and the billing module and have executed my first recurring invoice run today, but already clients have complained as I've a few problems which I hope you can help me with.

Firstly, my email templates reference {INVOICE_PAY_LINK} but this link in the emails themselves ended up screwed :

http://_/billing/payments/pay.php?id...d181e3f847b3ea

Secondly, if I replace the _ with the server name it should be, I get :

"Payment page has been disabled for this invoice."

Note that my server only runs HTTPS so the link should also reflect this but I'm not sure where or how to specify this.

Everything else is working fine but obviously billing is an important feature so I need this to be correct. On my Global Settings -> Payment gateways configuration I have all fields specified and PayPal enabled, other than "Link to payment page (otional)" which I understood was only to replace the default URL which should have been correct, above.

I have noticed that on the Billing -> Client List -> Settings the Payment Gateway is set to "None" - does this need to be "Auto" for all clients in order to work as I expect it to ?

Thanks in advance,

Matt.

till 4th June 2012 14:17

Quote:

Everything else is working fine but obviously billing is an important feature so I need this to be correct. On my Global Settings -> Payment gateways configuration I have all fields specified and PayPal enabled, other than "Link to payment page (otional)" which I understood was only to replace the default URL which should have been correct, above.
Set the correct URL that matches your installation for the billing gateway page under Global Settings -> Payment gateways > Link to payment page (otional)

The link has to be like this:

Code:

http://www.yourdomain.tld:8080/billing/payments/pay.php?id=
where "www.yourdomain.tld:8080" is the URL and port were your ispconfig controlpanel can be reached. The URL in this field has to end with =, the ID is added at the end automatically.

Quote:

I have noticed that on the Billing -> Client List -> Settings the Payment Gateway is set to "None" - does this need to be "Auto" for all clients in order to work as I expect it to ?
Non means disabled, so its correct that you get the error message that you disabled the billing gateway.

If you need help with the billing module, please contact our support by email to support [at] ispconfig [dot] org.


All times are GMT +2. The time now is 04:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.