HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Mailbox password change problem (http://www.howtoforge.com/forums/showthread.php?t=57519)

vexcor 4th June 2012 12:24

Mailbox password change problem
 
Hello we updated our servers to 3.0.4.5 and we have problem with edit mailbox user. Password change doesnt work. We are changing in standard way via admin and mailbox edit form. After submit form with new password interface said save, but any changes. Password still old one. Any other changes as forwarder, mail copy, autorespond etc. work without problem, only change password doesnt work.
We have setup with two servers:
Server 1: www, dns, mysql
Server 2: mail, dns
I tried find some errors in logs but nothings on both servers. I tried mysql permissons too, but all settings is good without errors.
Where can be problem? We need fix it, its very big problem!

till 4th June 2012 12:30

See FAQ for instructions on how to debug a ispconfig server:

http://www.faqforge.com/linux/debugg...-of-a-failure/

You have to run the server.sh script on the slave in debug mode.

vexcor 4th June 2012 15:56

I tried it and nothings in log, here is output:
master:
04.06.2012-12:35 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
04.06.2012-12:35 - DEBUG - No Updated records found, starting only the core.
04.06.2012-12:35 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

slave:
04.06.2012-12:49 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
04.06.2012-12:49 - DEBUG - No Updated records found, starting only the core.
04.06.2012-12:49 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

till 4th June 2012 16:06

Change a mailbox password and then run the script on the lave again.

vexcor 4th June 2012 16:52

Still same, only new one, but its another problem with OpenVz.
FATAL: Error inserting ip_tables (/lib/modules/2.6.32-7-pve/kernel/net/ipv4/netfilter/ip_tables.ko): Operation not permitted

till 4th June 2012 17:43

And you areareally sure that you disabled (commented out) the server.sh cronjob in the root crontab of the slave server as described in the FAQ?

vexcor 4th June 2012 17:59

Yes, cron is commented and disabled, but still only:
04.06.2012-14:56 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
04.06.2012-14:56 - DEBUG - No Updated records found, starting only the core.
04.06.2012-14:56 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

vexcor 4th June 2012 18:09

I tried look to the database after update and in database on master server in table mail_user is password changed. I will try look to the slave mysql, maybe some problem in synchronization between servers. But in mysql log on slave is all without problem.

till 4th June 2012 18:14

The server.sh script is the synchronisation script of the dbispconfig databases on master and slave, so you should see the sync when you run it manually. Please note that only ispconfig can sync the records between the local database of the master and the local database of the slave, if you installed any other kind of sync, then the system will fail to update its records.

Which guide did you use to install the servers?

vexcor 4th June 2012 18:57

Servers is installed about 2 years ago, many versions before worked without problem, after update to 3.0.4.5 has this problem. I tried revert this containers on my localmachine to version 3.0.4.4 and everything work like a charm, so problem must be in somethings new in 3.0.4.5.
Servers is installed with this tutorial http://www.howtoforge.com/installing...th-ispconfig-3
we have only changes in server roles. We have only two servers.
I tried SELECT on slave and there is old password, problem must be in synchronization. But permissions are granted, any error in mysql on bot servers. Is somethings new in the synchronization or installer??


All times are GMT +2. The time now is 22:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.