HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ubuntu VPS running ISPconfig + nginx 1gb ram 100% (http://www.howtoforge.com/forums/showthread.php?t=57506)

iain17 3rd June 2012 02:18

ubuntu VPS running ISPconfig + nginx 1gb ram 100%
 
Hi there,
I had ISPconfig running fine on ubuntu with apache installed, but out of curiosity and need for more speed I backed up my whole server and reinstall it planning on installing ispconfig again but this time using Nginx.
I follewed this guide:http://www.howtoforge.com/perfect-se...nx-ispconfig-3 and got it installed.

I kept looking at the memory useage, and all was fine untill the last step installing ispconfig setup.php and the moment it hit this:
Quote:

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) and then start(8) utilities,
e.g. stop mysql ; start mysql. The restart(8) utility is also available.
My memory usage started rising to 96 - 99% until, I tried using my new user and yes the pages loaded fast but when after a few moments of using it.
It just crashed because it was using 100% of it's memory.

Now I've been trying to fix this, by fiddling in the Nginx to make it as low of possible and still no luck, I began retracing my steps in the guide where I install Nginx, and sure enough I sort of found out what triggered the memory to spike to 100% and crash eventually.
When I removed the php5-mysql by using this command: apt-get remove php5-mysql my memory usage went back to 350mb ram instead of ~1000mb.
After installing it again, it resorted back to 100% usage.

This didn't happen before I install ISPconfig, the moment I finished setup.php I got this problem going and after hours of trying to figure out why this happend I'm hoping one of you guys can help me out.

+I need to point out that I've made several attempts by reinstalling it, but for some reason php5-mysql becomes a trouble maker when it is used in combination with ispconfig. And Ispconfig needs php5-mysql otherwise it won't run of course ;).
I've also disabled clam to relieve some stress on the memory, but that free up is instantly taken and filled up making it around 100% again :(

Some help or pointers on what I did wrong would quite frankly be awesome,
Iain

iain17 3rd June 2012 17:31

Ah after contacting my vps provider, I found out that 11.10 installation was actually 11.04, they made a mistake somehow giving me an 11.04 installation.

Anways I updated to 11.10 using this guide: http://www.howtoforge.com/how-to-upg...-and-server-p2
and it worked fine, this thread can be closed.

Iain


All times are GMT +2. The time now is 14:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.