HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   CentOS 6.2 & kvm on hetzner (http://www.howtoforge.com/forums/showthread.php?t=57446)

imonkey 29th May 2012 19:06

CentOS 6.2 & kvm on hetzner
 
I have been following this tutorial on a Hetzner server.
http://www.howtoforge.com/virtualiza...tos-6.2-server

When i get to the bridge networking bit, i follow the guide but when i restart the network it drops my ssh.

I am unsure what error it brings up as once i loose ssh i cannot login again and have to reinstall the OS.

Has anyone managed to get KVM installed on a Hetzner CentOS server? What do i need to do differently?

imonkey 29th May 2012 19:23

VirtualBox installs first time every time and allows me to bridge, i am unsure how their bridging works but i don't have to create the br0 interface - it seems to link directly to eth0. Is there a way i can do this with KVM?

falko 30th May 2012 16:18

I think you need to add routes for your IPs: http://wiki.hetzner.de/index.php/KVM...-_the_easy_way

imonkey 30th May 2012 16:26

Thanks for the reply, how would i do that in centos?

I don't think you need to route it anymore, just bridge as hetzner now allow you to generate a spoof mac address for an IP to set to a VM - (that is what i did with virtualbox and it picked up the IPs fine).
Then i can just leave the VM in dhcp mode and it will pickup the IP. I am new to KVM so it might still need to be routed?


All times are GMT +2. The time now is 17:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.