HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Could not find Pear DB library (http://www.howtoforge.com/forums/showthread.php?t=57348)

DodgeThis 19th May 2012 23:38

Could not find Pear DB library
 
Recently i update my ispconfig3 to 3.0.4.4 but now users can't change passwords on squirrelmail webmail.

when they try to change they password squirrelmail shows 'Could not find Pear DB library'

what i can do??
i have used this how to configure the plugins.

I'm using debian squeeze
and used:
http://www.howtoforge.com/perfect-se...ot-ispconfig-3
and
http://www.howtoforge.com/how-to-con...onfig-3-server

Installed packages, channel pear.php.net:
=========================================
Package Version State
Archive_Tar 1.3.7 stable
Auth 1.6.2 stable
Console_Getopt 1.2.3 stable
DB 1.7.14 stable
PEAR 1.9.1 stable
Structures_Graph 1.0.3 stable
XML_Util 1.2.1 stable

till 21st May 2012 09:16

Check the /etc/apache2/conf.d/squirrelmail.conf file, if it contains a open besdire path restrictions, then ensure that the location were there pear libraries are installed on your server are included in that path.

DodgeThis 22nd May 2012 11:23

Quote:

Originally Posted by till (Post 279390)
Check the /etc/apache2/conf.d/squirrelmail.conf file, if it contains a open besdire path restrictions, then ensure that the location were there pear libraries are installed on your server are included in that path.

Hi Till thanks for your reply but i'm little bit confused.
Here is my squirrelmail.conf.

Code:

Alias /squirrelmail /usr/share/squirrelmail
Alias /webmail /usr/share/squirrelmail
<Directory /usr/share/squirrelmail>
  Options FollowSymLinks
  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
    php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
    php_flag register_globals off
  </IfModule>
  <IfModule mod_dir.c>
    DirectoryIndex index.php
  </IfModule>

  # access to configtest is limited by default to prevent information leak
  <Files configtest.php>
    order deny,allow
    deny from all
    allow from 127.0.0.1
  </Files>
</Directory>

# users will prefer a simple URL like http://webmail.example.com
#<VirtualHost 1.2.3.4>
#  DocumentRoot /usr/share/squirrelmail
#  ServerName webmail.example.com
#</VirtualHost>

# redirect to https when available (thanks omen@descolada.dartmouth.edu)
#
#  Note: There are multiple ways to do this, and which one is suitable for
#  your site's configuration depends. Consult the apache documentation if
#  you're unsure, as this example might not work everywhere.
#
#<IfModule mod_rewrite.c>
#  <IfModule mod_ssl.c>
#    <Location /squirrelmail>
#      RewriteEngine on
#      RewriteCond %{HTTPS} !^on$ [NC]
#      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
#    </Location>
#  </IfModule>
#</IfModule>

Should i put the plugins folder somewhere here?

falko 23rd May 2012 14:13

Please change
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
to
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/usr/share/php

DodgeThis 23rd May 2012 16:18

Quote:

Originally Posted by falko (Post 279551)
Please change
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
to
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/usr/share/php

Thanks for your reply but still doesn't work.
Any suggestion?

dreamsky 25th May 2012 06:17

do this

Quote:

Originally Posted by falko (Post 279551)
Please change
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
to
Code:

php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/usr/share/php

and this

try to remove php_value include_path .

so your /etc/apache2/conf.d/squirrelmail.conf

like this

PHP Code:

<Directory /usr/share/squirrelmail>
  
Options FollowSymLinks
  
<IfModule mod_php5.c>
    
AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_admin_value upload_tmp_dir 
/var/lib/squirrelmail/tmp
    php_admin_value open_basedir 
/usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/usr/share/php
    php_flag register_globals off
  
</IfModule>
  <
IfModule mod_dir.c>
    
DirectoryIndex index.php
  
</IfModule


TY to Mr. Anton

DodgeThis 25th May 2012 13:13

Quote:

Originally Posted by dreamsky (Post 279679)
do this



and this

try to remove php_value include_path .

so your /etc/apache2/conf.d/squirrelmail.conf

like this

PHP Code:

<Directory /usr/share/squirrelmail>
  
Options FollowSymLinks
  
<IfModule mod_php5.c>
    
AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_admin_value upload_tmp_dir 
/var/lib/squirrelmail/tmp
    php_admin_value open_basedir 
/usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/usr/share/php
    php_flag register_globals off
  
</IfModule>
  <
IfModule mod_dir.c>
    
DirectoryIndex index.php
  
</IfModule


TY to Mr. Anton

Falco, Till & Dreamsky Thanks++ it solved my problems. Thanks to both. :)


All times are GMT +2. The time now is 03:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.