HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   cluster openfiler how-to help (http://www.howtoforge.com/forums/showthread.php?t=57299)

jeraisel 15th May 2012 16:13

cluster openfiler how-to help
 
Hello

I tried to follow the tutorial:
http://www.howtoforge.com/openfiler-...maker-and-drbd


The tutorial is great and I tried to follow step by step but I didn't get it to work.

running crm_mon I get the following output:

Code:

Attempting connection to the cluster...

============

Last updated: Tue May 15 10:18:32 2012

Stack: openais

Current DC: cluster1 - partition with quorum

Version: 1.1.2-c6b59218ee949eebff30e837ff6f3824ed0ab86b

2 Nodes configured, 2 expected votes

4 Resources configured.

============

Online: [ cluster2 cluster1 ]

 Resource Group: g_services

        lvmdata                (ocf::heartbeat:LVM):          Started cluster2

        openfiler        (lsb:openfiler):                Stopped

        ClusterIP        (ocf::heartbeat:IPaddr2):        Stopped

        iscsi                (lsb:iscsi-target):            Stopped

        samba                (lsb:smb):                        Stopped

        nfs                (lsb:nfs):                        Stopped

        nfslock                (lsb:nfslock):                  Stopped



 Master/Slave Set: ms_g_drbd

        Masters: [ cluster2 ]

        Slaves: [ cluster1 ]



Failed actions:

    nfs-lock_start_0 (node=cluster1, call=16, rc=1, status=complete): unknown e


I misspelled the corosync command:

Code:

order o_g_servicesafter_g_drbd inf: ms_g_drbd:promote g_services:start
I've read in one of the comments that it was supposed to be:

Code:

order o_g_services_after_g_drbd inf: ms_g_drbd:promote g_services:start
how do I correct it?

here is the output of the crm configure show command:

Code:

node cluster1

node cluster2

primitive ClusterIP ocf:heartbeat:IPaddr2 \
        params ip="128.1.8.101" cidr_netmask="32" \
        op monitor interval="30s"

primitive MetaFS ocf:heartbeat:Filesystem \
        params device="/dev/drbd0" directory="/meta" fstype="ext3"

primitive drbd_data ocf:linbit:drbd \
        params drbd_resource="data" \
        op monitor interval="15s"

primitive drbd_meta ocf:linbit:drbd \
        params drbd_resource="meta" \
        op monitor interval="15s"

primitive iscsi lsb:iscsi-target

primitive lvmdata ocf:heartbeat:LVM \
        params volgrpname="data"

primitive nfs lsb:nfs

primitive nfs-lock lsb:nfslock

primitive nfslock lsb:nfslock

primitive openfiler lsb:openfiler

primitive samba lsb:smb

group g_drbd drbd_meta drbd_data

group g_services lvmdata openfiler ClusterIP iscsi samba nfs nfslock

ms ms_g_drbd g_drbd \
        meta master-max="1" master-node-max="1" clone-max="2" clone-node-max="1" notify="true"

colocation c_g_services_on_g_drbd inf: g_services ms_g_drbd:Master

order o_g_servicesafter_g_drbd inf: ms_g_drbd:promote g_services:start

property $id="cib-bootstrap-options" \
        dc-version="1.1.2-c6b59218ee949eebff30e837ff6f3824ed0ab86b" \
        cluster-infrastructure="openais" \
        expected-quorum-votes="2" \
        stonith-enabled="false" \
        no-quorum-policy="ignore"

rsc_defaults $id="rsc-options" \
        resource-stickiness="100"

also notice that the first two lines of the crm configure show are different from the expected output, I get:

Code:

node cluster1

node cluster2

instead of:
 node filer01 \

attributes standby="off"

node filer02 \
attributes standby="off"

Also I can't access the openfiler web interface.

Thank you in advance

Jera

antram 27th May 2012 20:52

No puedes acceder a la interface de openfiler porque el recurso ClusterIP esta parado.
El problema esta en el recurso nfslock que no funciona.
Creo que como ambos recursos esta agrupados en g_services si uno no arranca tampo lo hace el otro.

o_g_services_after_g_drbd = o_g_servicesafter_g_drbd.
Esto solo es el nombre del recurso y puedes poner lo que tu quieras.

A mi tampoco me funciona el recurso nfslock, si consigues arreglarlo avisame.

Saludos y disculpa por no contestarte en inglÚs. :)

jeraisel 28th May 2012 12:18

Thank you antram
 
Hi

Thank you for your reply, and I do understand Spanish, no problem.
I will investigate what you said, and if I get anywhere I'll post it on the forum.

Thanks again

jeraisel


All times are GMT +2. The time now is 10:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.