HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   apache virtualhosts permission deneid (http://www.howtoforge.com/forums/showthread.php?t=5725)

rolamento 22nd July 2006 20:22

apache virtualhosts permission deneid
 
Hi.
Im almost going crazy and giving up.
I have suse 10.1 and no matter what i do im unable to put apache virtualhosts to work always get permission denied.

im using two domains for testing purposes one www.xxx.info configured with zoneedit and onother from dydns since i have a dynamic ip address.

They both resolve right to my machine with ddclient, however apache isnt doing is job.

The only way to get to the page is directly with http://www.xxx.info/web4/web/

I dont have any log errors from apache.

Thank you for your help.


Here is my httpd.conf


Quote:



Include /etc/apache2/uid.conf

Include /etc/apache2/server-tuning.conf

ErrorLog /var/log/apache2/error_log

Include /etc/apache2/sysconfig.d/loadmodule.conf

Include /etc/apache2/listen.conf

Include /etc/apache2/mod_log_config.conf

Include /etc/apache2/sysconfig.d/global.conf

Include /etc/apache2/mod_status.conf

Include /etc/apache2/mod_info.conf

Include /etc/apache2/mod_usertrack.conf

Include /etc/apache2/mod_autoindex-defaults.conf

TypesConfig /etc/apache2/mime.types
DefaultType text/plain
Include /etc/apache2/mod_mime-defaults.conf

Include /etc/apache2/errors.conf

Include /etc/apache2/ssl-global.conf

<Directory />
Options None
AllowOverride None
Order deny,allow
Deny from all
</Directory>

AccessFileName .htaccess
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>

DirectoryIndex index.html index.htm index.shtml index.cgi index.php index.php5 index.php4 index.php3 index.pl index.html.var index.aspx default.aspx

Include /etc/apache2/default-server.conf


Include /etc/apache2/sysconfig.d/include.conf


### Virtual server configuration ############################################
Include /etc/apache2/vhosts.d/*.conf

<Directory /var/www/sharedip>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /srv/www/*/web>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

<Directory /srv/www/*/user/*/web>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

<Directory /srv/www/*/cgi-bin>
Options ExecCGI -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
and
Quote:

###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.2.1:80
<VirtualHost 192.168.2.1:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: dominiovirtual.dnsdojo.org:80
######################################
#
#
<VirtualHost 192.168.2.1:80>
ServerName dominiovirtual.dnsdojo.org:80
ServerAdmin webmaster@dnsdojo.org
DocumentRoot /srv/www/web2/web
ServerAlias dnsdojo.org
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web2/log/error.log
Alias /error/ "/srv/www/web2/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web2/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web2/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: www.dominiovirtual.info:80
######################################
#
#
<VirtualHost 192.168.2.1:80>
ServerName www.dominiovirtual.info:80
ServerAdmin webmaster@dominiovirtual.info
DocumentRoot /srv/www/web4/web
ServerAlias dominiovirtual.info
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /srv/www/web4/log/error.log
Alias /error/ "/srv/www/web4/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web4/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web4/user/$1/web/$3
</VirtualHost>
#
#
#

till 22nd July 2006 20:43

Have you tried to disable apparmor, if it is currently enabled?

rolamento 23rd July 2006 00:34

apparmor
 
yes its off.
i have followed the perfect suse config.:(

rolamento 23rd July 2006 01:36

Its Working
 
Thank you for your help.

I really dont know yet how i did it

however this is what i have done:

i Have installed apache2-mod-apparmor (even with apparmor off)
i have remarked the create DNS checkmark.

Now everything its ok

Hoppe it could help anyone with the same problem.

Thank you


All times are GMT +2. The time now is 23:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.