HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) (http://www.howtoforge.com/forums/showthread.php?t=57247)

Kalyptos 10th May 2012 22:28

The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)
 
Hello. nice tutorial, but after doing this from a cleane install, and i setup my site on the isp control panel , and uploaded my wordpress files isntalled it and everything whent smood without any errors. HOW EVER, when i try to upload any files trough wordpress i get a internal server error 500, ive resintall and tryed everything still the same.. ANY clues anyone??

falko 11th May 2012 10:09

Which PHP mode do you use? Did you check Apache's and the web site's error logs?

Kalyptos 11th May 2012 17:21

the apache2 error log gives me this :
Code:

[Thu May 10 21:47:03 2012] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.3.10-1ubuntu3.1 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(201$
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
[Fri May 11 17:07:15 2012] [error] [client 10.0.0.49] File does not exist: /var/www/favicon.ico
[Fri May 11 17:07:15 2012] [error] [client 10.0.0.49] File does not exist: /var/www/favicon.ico
[Fri May 11 17:07:15 2012] [error] [client 10.0.0.49] File does not exist: /var/www/favicon.ico
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly

i will check my php mods.. but i guess the mods are as the tutorial

till 11th May 2012 17:23

Pleasetry the fix suggested here in the ISPConfig FAQ:

http://www.faqforge.com/linux/fix-ht...-debian-linux/

And in ISPConfig, check that you selected the php mode "php-fcgi" in the website settings and that suexec is enabled in the website settings.

Kalyptos 11th May 2012 17:29

Thanks man :D that did it.. omg ive reinstalled alot of times because of that bug. had the same problem with nginx :P


All times are GMT +2. The time now is 17:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.