HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPConfig 3 on Hetzner Ubuntu minimal (http://www.howtoforge.com/forums/showthread.php?t=57239)

McLure 10th May 2012 11:53

ISPConfig 3 on Hetzner Ubuntu minimal
 
I (and a friend on a similar server) got HTTP ERROR on Wordpress image upload on new Ubuntu 12.04 server at Hetzner ubuntu 12.04 minimal. I guess this has something to do with wrong setup or something.
At "The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) - Page 4"
( http://www.howtoforge.com/perfect-se...ispconfig-3-p4 )
I had to PURGE before INSTALL at "apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-sieve sudo" - otherwise the "General type of mail configuration: <-- Internet Site" do not show up and postfix never worked otherwise.
Could this be the reason for the HTTP ERROR ?

Would be nice with a "The Perfect Server @ Hetzner" guide...

till 10th May 2012 12:28

Quote:

I (and a friend on a similar server) got HTTP ERROR on Wordpress image upload on new Ubuntu 12.04 server at Hetzner ubuntu 12.04 minimal. I guess this has something to do with wrong setup or something.
First,ensure that you use the current ispconfig version (3.0.4.4). The reason for that are most likely wrong website settings. Wordpress requires the following settings:

System > Server config > Web: Security Level must be set to high.

Sites > Website:

Suexec: On
PHP mode: php-fcgi

and make sure that all files and folders from wordpress in the "web" folder of this site are owned by the user and group of this website.
Quote:

Could this be the reason for the HTTP ERROR ?
No.

MaddinXx 10th May 2012 12:56

I am not sure, but wasn't there already a simular question once?

I think the problem was the max. "string lenght" of the URL which had to be enhanced?

// edit: Something like this: http://www.howtoforge.com/forums/showthread.php?t=51163 ?

McLure 10th May 2012 17:41

Configuration..
 
Seems I have all correct. PHP is "Fast-CGI" - There is no "php-cgi"

till 10th May 2012 17:59

I guess what he meant is this topic which is described in the iSPConfig FAQ as well:

http://www.faqforge.com/linux/fix-ht...-debian-linux/

McLure 10th May 2012 18:14

Wow! That was all. Now it works!
MaxRequestLen 157286400


All times are GMT +2. The time now is 21:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.