HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   FTP doesnīt work (http://www.howtoforge.com/forums/showthread.php?t=57227)

erkan 9th May 2012 14:54

FTP doesnīt work
 
Hi

I have just now installed ISPConfig and ProFTPD. I have created a site and an FTP account in the ISPConfig control panel but when I try to login to the FTP account using my FTP client it just says "login incorrect".

Does someone know what I can do to find out what is wrong?

till 9th May 2012 15:23

ISPConfig requires pure-ftpd and not proftpd. Please see installation tutorials here on how to prepare your server to install ispconfig:

http://www.ispconfig.org/ispconfig-3/documentation/

erkan 9th May 2012 16:02

Ok, I tried PureFTPD first but couldnīt get that to work but I will try again.

till 9th May 2012 16:12

Which tutoriald did you use to prepare your server for the installation of ispconfig and is this a virtual server?

erkan 9th May 2012 16:16

Yes it is a virtual server, OpenVZ.

I used this guide:

http://library.linode.com/web-applic...bian-6-squeeze

And then I complemented with this for the FTP:

http://www.howtoforge.com/perfect-se...ispconfig-2-p5

till 9th May 2012 17:02

The guide from linode seems to be quite incomplete, many required packages and settings are missing.

I recommend to uninstall ispconfig with the uninstall.php script from the ispconfig tar.gz, then redo all steps from the official ispconfig tutorial starting with step 8:

http://www.howtoforge.com/perfect-se...ispconfig-3-p3

The pure-fpd package from Debian does not work on openvz by default as capabilities in openvz are disbaled. To install it, use this guide form ispconfig faq:

http://www.faqforge.com/linux/contro...ities-enabled/

do this right after you finished step 13 of the perfect server guide.

erkan 9th May 2012 17:03

Ok thanks! I will try that and get back to you when I have the result!

erkan 9th May 2012 17:44

Yes it worked! Thank you so very much!

erkan 11th May 2012 17:58

Ok now I got problems again.

When I follow this guide: http://www.faqforge.com/linux/contro...ities-enabled/

It seems that I have downloaded a newer version of pureftpd so the file names in the commands is wrong for me.

So far I have figured out that the version I have downloaded is 1.0.28. So I thought that I just change the commands. But there is one command that doesnīt work when I change it, this:

dpkg -i pure-ftpd-common_1.0.21-11.4_all.deb pure-ftpd-mysql_1.0.21-11.4_i386.deb

I tried to change it to:

dpkg -i pure-ftpd-common_1.0.28-11.4_all.deb pure-ftpd-mysql_1.0.28-11.4_i386.deb

But that didnīt work, I guess the -11.4 is supposd to be something else for my version but I donīt know what to change it to?

till 11th May 2012 17:59

Run:

ls -la

command in the direcotory after you compiled pure-ftpd and then install the .deb files that start with pure-ftpd-common and pure-ftpd-mysql that you find there.


All times are GMT +2. The time now is 18:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.