HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Centos 6.2 - a problem building courier with rpmbuild (http://www.howtoforge.com/forums/showthread.php?t=57042)

dimas 23rd April 2012 21:41

Centos 6.2 - a problem building courier with rpmbuild
 
Please kindly help me with a problem.

I'm now following the Perfect Server guide for Centos 6.2 with Apache. Now I'm stuck on page 4:

http://www.howtoforge.com/perfect-se...ispconfig-3-p4

The problem is - I can't build courier's rpm:

sudo rpmbuild -ta courier-authlib-0.63.0.tar.bz2

I get (after some processing) this error:

Segmentation fault

and then shortly afterwards the process stops with:
Bad exit status from ...

SeLinux is disabled, and otherwise the setup is followed strictly (except for the partitioning scheme, because I use software raid 1)

I don't know if it's pertinent, but I see the following messages during the boot-time, while loading udev

Failed to enable MSI-X

and also:
ACPI: I/O resource 0000:00:1f.3 [0xf040-0xf05f] conflicts with ACPI region SMBI [0xf040-0xf04f]

but udev starts with a green OK nonetheless

but later it says something like "catching up udev unfinished tasks" - and it also gives a green OK.

So, I wonder,

1. What could be the possible reason of my failing to rpmbuild courier-authlib?

2. Are the boot-time messages I've described above critical for a production system?

falko 24th April 2012 15:13

It's almost impossible to say why you get a segfault. There can be millions of reasons, for example a hardware failure...


All times are GMT +2. The time now is 21:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.