HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   DNS not working with ISPconfig3 (http://www.howtoforge.com/forums/showthread.php?t=56972)

melkij22 18th April 2012 09:48

DNS not working with ISPconfig3
 
Hi all,
I have question about DNS. I'm using opensuse 12.1 OS.
Also I have one server which is connected to internet via router with DMZ. ( I can connect to server and do whatever I want via external IP address ).
I have installed mydns and fresh install of ispconfig 3. ( done everything like was written in Perfect server guide )
Then I changed ns1 and ns2 at my domain registrator to :
ns1.mydomain.com ip : myexternalip
ns2.mydomain.com ip : myexternalip

Then I made dns records in ispconfig -> dns :
DNS Zone :
Code:

Zone ( SOA ) mydomain.com
NS ns1.mydomain.com
Email info@mydomain.com
Refresh 7200
Retry 540
Expire 604800
Minimum 86400
TTL 3600

And records :
Code:

        A        mydomain.com.        MyExternalIP        0       
        A        mail        MyExternalIP        0       
        A        www        MyExternalIP        0       
        MX        mydomain.com.        mail.mydomain.com.        10       
        NS        mydomain.com.        ns1.mydomain.com.        0       
        NS        mydomain.com.        ns2.mydomain.com.        0

Then I tryed to ping mydomain.com, but it is written :
Ping request could not find host mydomain.com. Please check the name and try again.


and here is dig
Code:

<<>> DiG 9.8.1-P1 <<>> mydomain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 38417
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.com.                        IN      A

;; Query time: 48 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Fri May 18 10:10:50 2012
;; MSG SIZE  rcvd: 32

What should I check or do?
Thanks

melkij22 18th April 2012 10:20

I managed to make it working. Just mydns was not working. :) so port 53 was closed.
Now another question - I have made domain and added website, but there is a problem - when I'm connecting from my ftp to domain and changed index file, browser still showing old ( standart ) index page not my new, why?

till 18th April 2012 11:55

If you uploaded a new index file,please ensure that you deleted the default index.html file from ispconfig.

melkij22 18th April 2012 12:18

Quote:

Originally Posted by till (Post 277710)
If you uploaded a new index file,please ensure that you deleted the default index.html file from ispconfig.

yes, I done it. Firstly deleted old index file, then uploaded new. Problem still exists

till 18th April 2012 12:23

Ensure that you enabled auto subdomain ww in the website settings. Also your dns records are incomplete, the a-records for ns1 and ns2 are missing.

melkij22 18th April 2012 12:27

Quote:

Originally Posted by till (Post 277715)
Ensure that you enabled auto subdomain ww in the website settings. Also your dns records are incomplete, the a-records for ns1 and ns2 are missing.

autosubdomain - www was enabled. I have added ns1 and ns2 A records, still problem the same

till 18th April 2012 12:38

Dekete all files with the name "index.html" in the "web" directory of the website as root user. Then restart apache and try again.

melkij22 18th April 2012 12:57

I have done it. Still problem exists.
I have created another domain and ftp user, when I'm connecting via ftp manager I can see that ipconfig creating everything fine, but when I'm browsing first or second domain I still see this standard index page ( but it is deleted from first and second domain )

melkij22 18th April 2012 13:05

As I see in FTP options - my site should be in /srv/www/clients/client1/web1 but when I'm opening that dir it's showing me that can't access that dir and there is no index file ( but in ftp I see index file )

till 18th April 2012 13:55

The website dir is /srv/www/clients/client1/web1/web and not /srv/www/clients/client1/web1 and in /srv/www/clients/client1/web1/web/ there must be a file named index.html and this file has to be deleted.


All times are GMT +2. The time now is 19:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.