HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   PHP & MySQL working, but AREN'T WORKING???? (http://www.howtoforge.com/forums/showthread.php?t=5697)

lipp9000 21st July 2006 15:02

PHP & MySQL working, but AREN'T WORKING????
 
I have MySQL installed and successfully working on ISPconfig, I also have phhmyadmin installed and i can access my databases and add tables and such so thats no problems.

PHP is enabled on a particular domain which has phpBB on it, that i wish to setup. When I'm filling in the install page i set these things:
Database type: MySQL 4.x/5.x
method: install
database server: my server ip
dbname: dbname (works in phpmyadmin)
db user: db user (works in phpmyadmin)
db pass: db pass (works in phpmyadmin)
and then my admin username and password

Then when I click install i get an error:
"The PHP configuration on your server doesn't support the database type that you chose"

Now...is there an extra thing you need to do to configure php with mysql? or should it be set automatically, keep in mind i followed the installation guide on the howtoforge fedoracore 5 page.

Why isnt php configured for mysql on that domain, ispconfig uses mysql and that works fine i can go to that.

Also i get an error in dreamweaver when im trying to connect to mysql, when i click test i get an error "HTTP Error code 405. Method not allowed". It's as if MySQL isnt there at all!!!

Any suggestions?? thanks very much in advance :D

fobicodam 21st July 2006 15:05

Try "database server: localhost"

lipp9000 21st July 2006 15:31

Nah that won't work because im trying to install it from a remote machine. But i'll try it on the linux box and see wot happens...

Nup, even on the linux box i get "The PHP configuration on your server doesn't support the database type that you chose"

fobicodam 21st July 2006 15:42

"localhost" as a server name works when the web page is on the same machine the mysql is. It doesnt matter if you are installing from New Zealand over a Iexplorer, because the php code runs on your server.

As i said, check your install steps, you miss something with php and its modules. Maybe you dont install the mysql modules.

till 21st July 2006 17:01

Please try waht fobicodam suggested, additionally some infos as you seem to meix something up.

Zhe IPCOnfig controlpanel uses its own PHP for the backend, if the backend works this does not mean that you installed PHP with mysql enabled for your websites.

Make sure that you have the php4-mysql or php5-mysql package from your linux distribution installed.


All times are GMT +2. The time now is 03:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.