HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Perfect Server Ubuntu 11.10 ISPConfig3 - FTP Issue (http://www.howtoforge.com/forums/showthread.php?t=56770)

Gaddam 3rd April 2012 05:01

Perfect Server Ubuntu 11.10 ISPConfig3 - FTP Issue
 
Greetings,

I just finished the entire setup followed in the tutorial.

The system services is showing FTP is offline, yet I'm able to connect to it using filezilla for my UNIX user/pass combo over SSH.

When I try to connect with the client ftp user I created I get an error:
Code:

Command:        Trust new Hostkey: Once
Command:        Pass: ***********
Error:        Authentication failed.
Error:        Critical error
Error:        Could not connect to server

I can't view the system log I get this error: Unable to read /var/log/messages

Thank You for the assistance.

till 3rd April 2012 07:32

Please post the output of:

netstat -tap | grep ftp

Is this a vserver?

Gaddam 3rd April 2012 15:46

It is not a vserver, and I used netstat -tap | grep ftp and nothing appeared.

I restarted and verified I did everything in the tutorial The perfect server Ubuntu 11.10 and then followed the guide for using an ssl key.

Code:

/etc/init.d/pure-ftpd-mysql restart
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -A -D -O clf:/var/log/pure-ftpd/transfer.log -E -Y 1 -u 1000 -H -8 UTF-8 -b -B

I viewed the system log via ssh, I found that it was complaining about pure-ftpd.pem not bieng found. I had to edit the pem file, when it's created it just appends it but not on a new line so I had to break the portion that -----BEGINS...----- onto a new line. Now when I run the above command I get this output:

Code:

tcp        0      0 *:ftp                  *:*                    LISTEN      16391/pure-ftpd (SE
tcp6      0      0 [::]:ftp                [::]:*                  LISTEN      16391/pure-ftpd (SE


Gaddam 3rd April 2012 16:21

ISPConfig3 reports that all services are running, but I still am unable to connect with a client that I created for my domain. I am able to connect using the linux/password for a system user.

So I still have to resolve why ISPConfig3 is unable to read the system log, and mail warn log. FTP connection from the client that should be able to connect over sftp using the ssl signed cert.

Thanks for your help and patience.

EDIT: syslog shows:

Apr 3 12:30:02 mail pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Apr 3 12:30:02 mail pure-ftpd: (?@127.0.0.1) [INFO] Logout.

falko 4th April 2012 00:47

Quote:

Originally Posted by Gaddam (Post 276678)
but I still am unable to connect with a client that I created for my domain.

Clients cannot use FTP. You must create an FTP user in ISPConfig.


All times are GMT +2. The time now is 23:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.