HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   How To Remotely Shut Down Windows XP Computers From A Linux Server (http://www.howtoforge.com/forums/showthread.php?t=56757)

hakova 2nd April 2012 06:52

How To Remotely Shut Down Windows XP Computers From A Linux Server
 
I followed this Howto step by step, and I am pretty sure I didn't miss anything. Unfortunately, when I issue the command from the linux box I get a message reading "Shutdown of remote machine succeeded" however nothing happens in the Windows box, not even the message is displayed.

Here are the specifications of the boxes:
  • Dell Optiplex 755, Windows XP SP3
  • Fedora 16 x86_64, samba 1:3.6.3-78.fc16

Code:

$ ping 192.168.1.126
PING 192.168.1.126 (192.168.1.126) 56(84) bytes of data.
64 bytes from 192.168.1.126: icmp_req=1 ttl=128 time=0.134 ms
64 bytes from 192.168.1.126: icmp_req=2 ttl=128 time=0.089 ms

64 bytes from 192.168.1.126: icmp_req=3 ttl=128 time=0.088 ms
64 bytes from 192.168.1.126: icmp_req=4 ttl=128 time=0.089 ms
^C
--- 192.168.1.126 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 0.088/0.100/0.134/0.019 ms

Code:

$ net rpc SHUTDOWN -C "Being remotely shutdown" -f -I 192.168.1.126 -U mcpc%

Shutdown of remote machine succeeded

Still no joy :(.

falko 2nd April 2012 10:33

Could it be a firewall issue? Please check the Windows firewall.

hakova 3rd April 2012 04:00

Thanks for the reply.

I followed the instructions, disabled simple file sharing, allowed the XP host to accept echo requests from the firewall settings. I also enabled the user specifically to issue remote forced shutdown from the local policy configuration, although he belonged to the administrators group. If it s a firewall issue, I must be missing something.:confused:

falko 4th April 2012 01:45

Are both computers in the same network? If not, you should check your router settings.

hakova 6th April 2012 06:20

I am sorry for the late reply, but the answer is yes. They are in the same network and the IPaddresses are set manually and fixed (i.e. no DHCP): 192.168.1.121 for the linux box and 192.168.1.126 for the windows one.

falko 7th April 2012 11:25

Have you tried to disable the Windows firewall for testing purposes?

hakova 9th April 2012 07:00

Yes I did, and it doesn't work. Neither the message is displayed, nor the XP box shuts down.


All times are GMT +2. The time now is 00:05.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.