HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   mx domains visible in google search causing duplicate content (http://www.howtoforge.com/forums/showthread.php?t=56737)

dynamind 30th March 2012 08:38

mx domains visible in google search causing duplicate content
 
hello,

there something really weird happening now, I check google for all index sites and found:

http://www.google.at/#hl=de&q=site:seo-werbeagentur.com

do you have an idea whats wrong suddenly?? the mx01 andd mx02 domains are indexed in google :S
this issues only appears on domains bought at domain.com ... not with domains registered at easyname or dot.tk
could it be an ISPconfig related issue or can it depend on the nameservers from domain.com?

till 30th March 2012 08:50

The issue itself is not caused by ispconfig, but there are some genarl considerations that you should do for all hosted websites when it comes to duplicate content:

1) Create only the nescessary dns records. E.g. ceate a a-record for the domain and a a-record for the www subdomain and dont use wildcard (*) DNS records.

2) Dont use wildcard subdomains in apache. Check your website settings and ensure that you use e.g. auto subdomain www and not auto subdomain *.

dynamind 30th March 2012 08:53

dns settings
 
http://img29.imageshack.us/img29/7038/dnsn.jpg

that's so curious, I have changed nothing and now this results!

till 30th March 2012 09:00

The mx01 and mx02 records dont come from this dns server. Either this dns server is not the authoritive dns server for the domain or the records are added in the dns server of the domain registrar directly.

dynamind 30th March 2012 09:08

http://img825.imageshack.us/img825/1498/domainc.jpg

do you see an error in the settings?
there is even something else I can't explain, I set the redirect to www. now and curl shows this result:

C:\windows\system32>curl -I www*mx01.semseo-agency*com
HTTP/1.1 301 Moved Permanently
Date: Fri, 30 Mar 2012 07:02:41 GMT
Server: Apache
location: hxxp://www.seo-werbeagentur.com/
Vary: Accept-Encoding
Content-Type: text/html

different domain, how come!

till 30th March 2012 09:22

You have a wildcard dns as I described above and this can cause your problem and should never be set if you care abot seo.

Regarding your curl test: the redirect is ok and recommended for seo.

dynamind 30th March 2012 09:32

yes till, but the redirect leads to a dfifferent domain:

C:\windows\system32>curl -I www*mx01.semseo-agency*com
HTTP/1.1 301 Moved Permanently
Date: Fri, 30 Mar 2012 07:02:13 GMT
Server: Apache
location: hxxp://www.seo-werbeagentur.com/
Vary: Accept-Encoding
Content-Type: text/html

I removed the wildcards and I don't know how this result gets resolved. The curiosity aside is:

http://www.google.at/#hl=de&q=site:rank-king.eu

http://img853.imageshack.us/img853/4282/dnsl.jpg

No problem with domains registered at easyname even with wildcards.
The dns from domain.com is devil-driving my server : ( when I use wildcards.

till 30th March 2012 09:49

Quote:

yes till, but the redirect leads to a dfifferent domain:

C:\windows\system32>curl -I www*mx01.semseo-agency*com
HTTP/1.1 301 Moved Permanently
Date: Fri, 30 Mar 2012 07:02:13 GMT
Server: Apache
location: hxxp://www.seo-werbeagentur.com/
Vary: Accept-Encoding
Content-Type: text/html
There are severalpossibilitys:

Check your .htaccess files and if you use cms systems, check tehs efor redirects too.

dynamind 30th March 2012 09:50

.htaccess already checked
 
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

this should be good, there's no cms, it pure html.

dynamind 30th March 2012 12:04

email server unreachable
 
I get this response now:

Hi. This is the qmail-send program at mailout-de.gmx.net.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<mymail@myserver.com>:
Sorry,_I_couldn't_find_a_mail_exchanger_or_IP_addr ess._(#5.4.4)/

clusterfu#!% ... I'll pull my domain and switch to easyname.


All times are GMT +2. The time now is 09:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.