HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   mailman & ispconfig 3.0.4.3 installation problem (http://www.howtoforge.com/forums/showthread.php?t=56692)

Giuseppe 26th March 2012 20:17

mailman & ispconfig 3.0.4.3 installation problem
 
Hi all,
i have some problem when install mailman on already existent ispconfig 3.0.4.3 installation.
I hope someone can help me.
My environment is:
Debian squeeze 6.0.4
ispconfig 3.0.4.3
ispconfig is installed on cp.mydomain.it on port 80

I had ispconfig already installed without mailman installation, but now i need mailman so i have do the follow:
apt-get install mailman
newlist mailman
added alias about mailman list in /etc/aliases
newaliases
/etc/init.d/postfix restart
/etc/init.d/mailman start
php -q update.php reconfiguring services

BUT:
after that up done when i go to http://cp.mydomain.it/mailman/listinfo i have:
not found The requested URL /mailman/listinfo was not found on this server.
if i go to: http://cp.zyzhsp.it/cgi-bin/mailman/listinfo i have:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Please help me!
Thank you for your collaboration.

Giuseppe

till 27th March 2012 07:50

Is cp.mydomain.it a website? If yes, is suexec enabled for the site?

Giuseppe 27th March 2012 08:39

Hi Till,
thank you for your help,
yes cp.mydomain.it is a website and exactly the website where my ispconfig control panel work and yes suexec is active on this website.
I have linked /etc/mailman/apache.conf to /etc/apache2/conf.d/mailman.conf exactly as is it in mailman directory and without active the virtual host comment out in it. Is it correct?
Thank you very much.

Giuseppe

falko 28th March 2012 12:50

Please disable suExec and try again.

Giuseppe 28th March 2012 12:52

Thank you very much, solved

baskin 5th April 2012 00:19

I have a similar issue after installing mailman, i'm getting url not found on both (admin and listinfo).

When i run

Code:

php -q update.php reconfiguring services
there is this:

Code:

Traceback (most recent call last):
  File "/usr/lib/mailman/bin/mailmanctl", line 106, in <module>
    from Mailman import mm_cfg
  File "/var/lib/mailman/Mailman/mm_cfg.py", line 76, in <module>
    DEFAULT_SERVER_LANGUAGE = en
NameError: name 'en' is not defined
Restarting Mailman master qrunner: mailmanctl

I have no suExec on the site and i'm on debian 6.

Thank you in advance.

baskin 5th April 2012 13:32

I've managed to go a little further.

I have started from scratch. I have created to web sites and two mail domains. The first is example.com and the second is lists.example.com.

I have created a list for the lists.example.com and now i can access the url http://lists.example.com/cgi-bin/mailman/admin/<list>, but it only displays

Quote:

Bug in Mailman version <undetermined>
and the email for the administrator has not been received. I can't find something useful on the logs (or i'm looking at wrong places).

I have followed the ispconfig's manual procedure numerous times without success.

Thanks again.

falko 5th April 2012 13:36

Quote:

File "/var/lib/mailman/Mailman/mm_cfg.py", line 76, in <module>
DEFAULT_SERVER_LANGUAGE = en
Use
Code:

DEFAULT_SERVER_LANGUAGE = 'en'
instead of
Code:

DEFAULT_SERVER_LANGUAGE = en
in /var/lib/mailman/Mailman/mm_cfg.py.

baskin 5th April 2012 13:38

Thanks falko, i have corrected this before you posted it. Check my second post.

baskin 5th April 2012 18:26

I want to summarize my findings after 3 installations from scratch with the same result on Debian 6.

All the installations have been done step step by the ISPConfig Manual.

After the installation, all services are started successfully including mailman.

The problems occurs as soon as i create a mailing list.

I want to host a single domain (for now) and a second one that is a subdomain but not point to the same space.

This install is for the Pirate Party Greece so if anyone want to help us please contact me or write here. It is a non profit installation and is based only on open source software.

I create the website "pirateparty.gr" and the website "lists.pirateparty.gr" because we want them to be separated. "pirateparty.gr" will host a wordpress, a phpbb forum, and a wiki. "lists.pirateparty.gr" will host the mailing lists and maybe something custom for reading the archives but not for now.

I also create to different email domains, "pirateparty.gr" and "lists.pirateparty.gr". The first one will have user accounts and the second is only for the lists.

So far everything is ok.

I enable for the "lists.pirateparty.gr" website CGI and Python (is that correct?) and after that i create a single mailing list for the email domain "lists.pirateparty.gr". After that mailman stops working with the following error:

Code:

/etc/init.d/mailman restart
Restarting Mailman master qrunner: mailmanctlTraceback (most recent call last):
  File "/usr/lib/mailman/bin/mailmanctl", line 107, in <module>
    from Mailman import Utils
  File "/var/lib/mailman/Mailman/Utils.py", line 368, in <module>
    def MakeRandomPassword(length=mm_cfg.MEMBER_PASSWORD_LENGTH):
AttributeError: 'module' object has no attribute 'MEMBER_PASSWORD_LENGTH'

Before the creation of the mailing list mailman was restarting without issues.

It is obvious that the urls http://lists.pirateparty.gr/cgi-bin/mailman/admin/<list> and listinfo are not working with "error 404 not found"

I have done the installation 3 times with the same result.

If someone has something to contribute or point me to, we will be grateful.

Thank you in advance

Stratos.


All times are GMT +2. The time now is 04:16.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.