HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Globally add /horde ? (http://www.howtoforge.com/forums/showthread.php?t=56607)

sjau 19th March 2012 18:57

Globally add /horde ?
 
Meanwhile I like the horde webmail suite very much. It provides webmail, calendar, todo, contact and can sync via SyncML, ActiveSync and supports caldav (or webdav... never really sure).

Anyway, I'd like to make horde available on all domains at /horde.

So I looked how phpmyadmin and squirrelmail are being handled. If found that those are stored in /etc/apache2/sites-available/ispconfig.conf

Code:

<Directory /usr/share/phpMyAdmin>
        Order allow,deny
        Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
        Order allow,deny
        Allow from all
</Directory>

Because of that, I thought I should add the horde info also there. So I added:

Code:

Alias /Microsoft-Server-ActiveSync /var/www/horde/rpc.php
Alias /horde /var/www/horde
<Directory /var/www/horde>
        Options +FollowSymLinks
        AllowOverride None
        order allow,deny
        allow from all
        php_value include_path ".:/usr/share/php"
        php_value open_basedir "none"
        php_value upload_tmp_dir "/var/www/horde/phptmp/"
</Directory>

After I restarted the webserver and used one of the domain I added, I got this error:

[Sun Mar 18 17:24:21 2012] [error] [client 127.0.1.1] SoftException in Application.cpp:221: File "/var/www/horde/index.php" is not in document root of Vhost "/var/www/clients/client1/web1/web"


However when I open it using the ip: http://ip_address/horde or http://hostname.com/horde it works.

till 20th March 2012 07:58

PLease add:

AddType application/x-httpd-php .php

right after the line

allow from all

This will switch the php mode to mod_php for the horde directory as the current ph mode of the site would prevent access to files outside of the web dir for security reasons.

sjau 20th March 2012 08:11

I'll try tonight.

Btw, should I add the horde stuff to the ipsconfig file or to apache2.conf?

till 20th March 2012 08:16

I would create a new file e.g. called horde.conf in the apache conf.d folder. apache will include all config files in conf.d automatically.

sjau 20th March 2012 17:59

that works perfectly.

alexander.bluemm 13th May 2012 10:23

Quote:

Originally Posted by till (Post 275818)
PLease add:

AddType application/x-httpd-php .php

right after the line

allow from all

This will switch the php mode to mod_php for the horde directory as the current ph mode of the site would prevent access to files outside of the web dir for security reasons.

Hi Till,

this works perfect.:)


All times are GMT +2. The time now is 11:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.