HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   phpMyAdmin not working (http://www.howtoforge.com/forums/showthread.php?t=56487)

shakethefloor 9th March 2012 15:23

phpMyAdmin not working
 
I have finally got everything set up on my vps, apart from phpmyadmin!

its a debian lenny with bind and dovecot

At first I just couldn't load the /phpmyadmin URL, either on the IP or on my domain, So I googled the problem, tried a reinstall and made a symlink to /var/www/phpmyadmin from /etc/phpmyadmin but when i browse to domain.co.uk/phpmyadmin (or /etc/phpmyadmin for that matter) I get these files:
Code:

apache.conf            config.header.inc.php  htpasswd.setup  phpmyadmin
config.footer.inc.php  config.inc.php        lighttpd.conf

But no index.php or anything. I took a look in the apache.conf and config.inc.php files but I had no idea if anything needed changing or why it wasn't working.

Thanks

till 9th March 2012 15:40

Please remove the symlink that you made.

Then run:

dpkg-reconfigure phpmyadmin

and select that apt shall configure phpmyadmin for apache (items get selected with the space bar on the keyboard). Afterwards restart apache.

shakethefloor 9th March 2012 21:17

Solved it again, thank you so much.

I realise where I went wrong. In the initial set up I pressed Enter instead of Space to select which one i wanted, so it was a blank selection.

Thanks again.


All times are GMT +2. The time now is 17:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.