HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   proftpd not working on fresh ispconfig/debian install (http://www.howtoforge.com/forums/showthread.php?t=56459)

shakethefloor 7th March 2012 01:23

proftpd not working on fresh ispconfig/debian install
 
I got an unmanaged VPS last week and before that I was completely new to Linux. I set it up with CentOS and I started to get used to that, but wanted ISPConfig installed and the recommended OS was Debian, and seen as I have no ties to CentOS I decided to switch.

I used the VPS Control Panel that I got with the VPS to reinstall the OS to Debian 5.0, and followed the Perfect Server with BIND and Dovecot tutorial (for ISPConfig 3), and hit some problems when I was at the Installing FTP part.

When it told me to restart the ftp server, it said something couldnt be found (i'm not too sure what it was, as i'm new to all this). I skipped the FTP steps as I just wanted to get everything installed, but now I can't get it working at all.

I used apt-get to remove the proftpd and used a different tutorial to install that, but it still won't start. Now i'm not sure what to remove to get rid of the new one I installed, and i'm absolutely lost on what to do with getting FTP working.

Sorry if I have missed out any information, not sure what is needed.

Thanks

kwickcut 7th March 2012 03:15

what is the link to the howto that you used
Quote:

Originally Posted by shakethefloor (Post 275010)
followed the Perfect Server with BIND and Dovecot tutorial (for ISPConfig 3), and hit some problems when I was at the Installing FTP part.

what one did you use?
Quote:

Originally Posted by shakethefloor (Post 275010)
I used apt-get to remove the proftpd and used a different tutorial to install that, but it still won't start. Now i'm not sure what to remove to get rid of the new one I installed, and i'm absolutely lost on what to do with getting FTP working.


till 7th March 2012 09:30

You mix up the FTP applications here, ispconfig does not support proftpd, it uses pure-ftpd which is a different ftp server program.

The pure-ftpd installation steps are described in the perfect server tutorial. If you used a different guide to install a ftp daemon, then it will most likely not work with ispconfig. If your provider uses openvz and has capabilities disabled, then you can install pure-ftpd as described here:

http://www.faqforge.com/linux/contro...ities-enabled/

shakethefloor 7th March 2012 14:29

Brilliant cheers. I can see how I got mixed up haha.

I'll try this now

Thanks

UPDATE: it worked perfectly, everything I needed was on that page, and when I was done I just gave my VPS a reboot and everything was fine, the ftp server was shown as running in the Services Monitor too.

Thanks again


All times are GMT +2. The time now is 09:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.