HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   weird behavior of https sites with the startssl certificate (http://www.howtoforge.com/forums/showthread.php?t=56452)

Ovidiu 6th March 2012 14:24

weird behavior of https sites with the startssl certificate
 
I followed the howto: http://www.howtoforge.com/securing-y...-from-startssl

Running an ISPCFG 3 Debian6 installation.

I got a level 2 certificate wildcard, multidomain from startssl.

certificate works fine for https and email BUT:


the only domain that I activated ssl for inside the ISPCFG3 control panel is: premaman.co.za so as expected https://www.premaman.co.za works fine.

If I enter another domain hosted on the same server and prefix it with https it wil show the content of the only domain with ssl activated, i.e. check out: https://zice.ro or https://pacura.ru they both show the content of https://www.premaman.co.za

can this behavior be stopped? I don't think that is very professionally to show the content of another website under a foreign domain?

Or did I do something wrong here?

till 6th March 2012 14:33

What you describe is the normal behaviour of SSL and not related to the use of ispconfig or startssl. For that reason there should be no other websites pointing to the same IP address then the ssl enabled domain.

Ovidiu 7th March 2012 09:17

:-) thanks for lifting the mystery, I remember now that you need a dedicated IP for each SSL enabled vhost.


All times are GMT +2. The time now is 02:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.