HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Issues with dummy slave (http://www.howtoforge.com/forums/showthread.php?t=56411)

mkreder 2nd March 2012 21:49

Issues with dummy slave
 
Hi,

I've installed ispconfig 3.0.4.3 as master/slave in Centos 6.2. Master was installed first, I've created a couple of DBs, sites, and DNS records.
Then, I installed the same version on the slave node, gave it the master root mysql password and the installation went just fine.
In both cases, I used root mysql users as indicated in the HowTo during the setup.
Now the issues is that if I create a site in the master panel but using the slave server as server, it does nothing, it appears in the master panel as green but it never shows up in the slave server nginx configuration.
If I log into the slave web panel, I don't see this site create neither any other site in the master it looks like an empty server.
If I go to the DNS sync tool in the slave server it doesn't find any record to replicate.
Looks like the slave server is not pulling the information from the master mysql database.

I tried to find errors in /var/log/ispconfig/ispconfig.log but they are empty..
any idea?

falko 3rd March 2012 12:17

Are there any errors in ISPConfig's Monitor module?

It works fine for me (also with nginx, but on Debian Wheezy).

Did you disable SELinux?

mkreder 5th March 2012 21:53

Nothing in the monitor module:

For the slave node it shows:

Code:

CPU Info (Server : lglass.example.com)

Data from: ????-??-?? ??:??

No data about the CPU available at the moment. Please check again later.

from both the master and the slave. And nothing in the "system-log"

SELinux is disabled for me, I running both the master and slave in OpenVZ containers.

mkreder 5th March 2012 23:14

Issue looks solved by following this:
http://www.howtoforge.com/forums/arc...p/t-48659.html

the key was: "Login to ispconfig on the master server, go to the server settings of the slave server and select that this server is a slave server of the master. The settings is named "is mirror of". This new setting will only affect new created domains or updated domains."

Haven't find that before

mkreder 5th March 2012 23:49

Well, this is a little bit confusing... Now I cannot create sites in the slave because it is mirrored with the master.. But I don't get the mirror concept here.

The mirror only mirrors the conf? not the database or the web directory?
In some forums it says that the master/slave conf was to manage all the servers from 1 sigle panel. I would like this feature more that mirroring just the conf.

I just need DNS mirroring...

Could someone clarify please?

till 6th March 2012 11:00

Quote:

The mirror only mirrors the conf? not the database or the web directory?
Yes. For the mirroring configuration that includes the database and the web directory see mirro setup guides.

http://www.howtoforge.com/installing...th-ispconfig-3

Quote:

In some forums it says that the master/slave conf was to manage all the servers from 1 sigle panel. I would like this feature more that mirroring just the conf.
Thats the default and you disabled it by switching to mirror mode. So to get the faeture back, disable mirroring under system > server services.


All times are GMT +2. The time now is 06:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.