HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   How to fix imapd No such file or directory? (http://www.howtoforge.com/forums/showthread.php?t=56339)

Icon 27th February 2012 09:43

How to fix imapd No such file or directory?
 
Hello, all
I tried to install postfix on Ubuntu 11.10 by tutorial http://www.howtoforge.com/virtual-us...l-ubuntu-11.10
but got an error quota patching http://www.howtoforge.com/forums/showthread.php?t=55770
I don't know how to fix so tried to go without it
But now mailx user@example.com gives this error:
Code:

Feb 27 12:31:01 example postfix/pickup[1466]: 927E14298B: uid=0 from=<root>
Feb 27 12:31:01 example postfix/cleanup[6389]: 927E14298B: message-id=<20120227073101.927E14298B@mail.example.com>
Feb 27 12:31:01 example postfix/qmgr[1467]: 927E14298B: from=<root@example.com>, size=312, nrcpt=1 (queue active)
Feb 27 12:31:01 example postfix/smtp[6392]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Feb 27 12:31:01 example postfix/smtp[6392]: 927E14298B: to=<user@example.com>, relay=none, delay=0.16, delays=0.14/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

/home/vmail folder's owners root and group vmail where is users vmail and postfix
When trying to login by squirrelmail it gives out Conenction refused by IMAP server and /var/log/mail.log says
Code:

Feb 27 12:11:24 example imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 27 12:11:24 example imapd: chdir example.com/user/: No such file or directory
Feb 27 12:11:24 example imapd: user@example.com: No such file or directory

If I create /home/vmail/example.com/icon by myself squirrelmail says
Code:

Query: CREATE "INBOX.Sent" Reason Given: Cannot create this folder.
May it be because of not quota patching? and how I can fix this at all?

falko 28th February 2012 18:19

Quote:

Feb 27 12:31:01 example postfix/smtp[6392]: 927E14298B: to=<user@example.com>, relay=none, delay=0.16, delays=0.14/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Looks as if amavisd isn't running. Please restart it.

Icon 29th February 2012 07:06

restarted amavis, but still this log after mailx and no folder in /home/vmail
Code:

Feb 29 09:57:35 example postfix/pickup[1480]: 8F9A74293B: uid=0 from=<root>
Feb 29 09:57:35 example postfix/cleanup[2061]: 8F9A74293B: message-id=<20120229045735.8F9A74293B@mail.example.com>
Feb 29 09:57:35 example postfix/qmgr[1481]: 8F9A74293B: from=<root@example.com>, size=310, nrcpt=1 (queue active)
Feb 29 09:57:38 example postfix/smtpd[1999]: connect from localhost[127.0.0.1]
Feb 29 09:57:38 example postfix/smtpd[1999]: 2383B42936: client=localhost[127.0.0.1]
Feb 29 09:57:38 example postfix/cleanup[2061]: 2383B42936: message-id=<20120229045735.8F9A74293B@mail.example.com>
Feb 29 09:57:38 example postfix/qmgr[1481]: 2383B42936: from=<root@example.com>, size=718, nrcpt=1 (queue active)
Feb 29 09:57:38 example amavis[2057]: (02057-01) Passed CLEAN, <root@example.com> -> <user@example.com>, Message-ID: <20120229045735.8F9A74293B@mail.example.com>, mail_id: culJ4iOZEHNm, Hits: -0.001, size: 310, queu$
Feb 29 09:57:38 example postfix/smtp[2062]: 8F9A74293B: to=<user@example.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2.7, delays=0.09/0.02/0.02/2.5, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:1$
Feb 29 09:57:38 example postfix/qmgr[1481]: 8F9A74293B: removed
Feb 29 09:57:38 example postfix/smtp[2066]: 2383B42936: to=<user@example.com>, relay=none, delay=0.44, delays=0.03/0.02/0.38/0, dsn=5.4.6, status=bounced (mail for mail.example.com loops back to myself)
Feb 29 09:57:38 example postfix/cleanup[2061]: 98E5442944: message-id=<20120229045738.98E5442944@mail.example.com>
Feb 29 09:57:38 example postfix/qmgr[1481]: 98E5442944: from=<>, size=2512, nrcpt=1 (queue active)
Feb 29 09:57:38 example postfix/bounce[2067]: 2383B42936: sender non-delivery notification: 98E5442944
Feb 29 09:57:38 example postfix/qmgr[1481]: 2383B42936: removed
Feb 29 09:57:38 example postfix/smtp[2066]: 98E5442944: to=<root@example.com>, relay=none, delay=0.33, delays=0.03/0/0.3/0, dsn=5.4.6, status=bounced (mail for mail.example.com loops back to myself)
Feb 29 09:57:38 example postfix/qmgr[1481]: 98E5442944: removed

looks like mailx can't deliver message but I don't know reason

falko 1st March 2012 20:57

Quote:

Feb 29 09:57:38 example postfix/smtp[2066]: 98E5442944: to=<root@example.com>, relay=none, delay=0.33, delays=0.03/0/0.3/0, dsn=5.4.6, status=bounced (mail for mail.example.com loops back to myself)
Please add mail.example.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.

Icon 2nd March 2012 06:33

Quote:

Originally Posted by falko (Post 274681)
Please add mail.example.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.

mydestination is already mail.example.com, localhost, localhost.localdomain
here full main.cf
Code:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mail.example.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mail.example.com, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 192.168.10.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mys$
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, re$
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_lim$
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota$
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $vir$
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings


falko 3rd March 2012 12:04

Was it there all the time, or did you recently add it without restarting Postfix? Do you still get the error in your mail log?

Icon 5th March 2012 06:23

Quote:

Originally Posted by falko (Post 274757)
Was it there all the time, or did you recently add it without restarting Postfix? Do you still get the error in your mail log?

It's here from beginning
I restarted it many times, even reboot server
And still same error
I read in some forum that it's because of exceeding quota limit, that returned me to think reason is in no quota patch

falko 5th March 2012 18:35

Did you use the correct quota patch for your Postfix version?

Icon 6th March 2012 06:12

Quote:

Originally Posted by falko (Post 274884)
Did you use the correct quota patch for your Postfix version?

No, I said i didn't used any quota patch because of this http://www.howtoforge.com/forums/showthread.php?t=55770 error
Postfix 2.8.5
Quota patch postfix-vda-v10-2.8.5.patch

falko 7th March 2012 18:12

Did you follow the tutorial as closely as possible? For example, did you disable dash? I've never had any problems building Postfix with the quota patch.


All times are GMT +2. The time now is 19:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.