HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   enabling https:// for specific domains (http://www.howtoforge.com/forums/showthread.php?t=56238)

dynamind 20th February 2012 12:46

enabling https:// for specific domains
 
Since october 11 facebook requires a secured connection for fanpages, so I tried to enable https for a domain but apache2 failed to start.
I entered all data in the SSL Panel except SSL Request, SSL Certifikat& SSL Bundle.
Then I changed SSL Action to "Save Certificate". After that apache2 crashed, I wasn't able to restart the webserver.

Is ISPconfig3 able to create the SSL keys or do I have to pre-create the keys with openssl? What's the correct/best way to enable SSL for domains?

till 20th February 2012 13:18

Quote:

Is ISPconfig3 able to create the SSL keys
Yes.

Quote:

or do I have to pre-create the keys with openssl?
No.

Quote:

What's the correct/best way to enable SSL for domains?
Select a IP address in the website settings and enable the ssl checkbox, then enter the details of the ssl cert on the ssl tab of the website. make sure that you dont enter any special chars as this can cause openssl to fail to create the correct certs. Then choose create certificate as action and click on save.

This is described in detail in the manual.

dynamind 20th February 2012 13:23

I bought your manual
 
thanks, I see & I guess the wildcard was my fault.
updated: works!
till, you're my webhosting-panel-god ; )

kwickcut 20th February 2012 22:48

i have tried this but when i type in the url for the site i want to use the ssl cert on i am directed to the main server page..

Code:

http://server.com is the same as https://mysite.com
how do i get around this

dynamind 26th February 2012 18:52

error 501
 
don't know why but now I get errors with SSL, I posted here

net::ERR_INSECURE_RESPONSE

http://www.howtoforge.com/forums/sho...74310&posted=1

updated: facebook 501 SSL error unsolved


All times are GMT +2. The time now is 00:06.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.