HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Powerdns and zero serials on new zones (http://www.howtoforge.com/forums/showthread.php?t=56007)

Jorma 31st January 2012 16:30

Powerdns and zero serials on new zones
 
I user powerdns (and -plugin) and when I add new zone using template, the zone will get zero as serial until i make some change or add new record for the zone.

Looks like it also ignores my refresh/retry etc. times in template and writes only "ns1.server.foo email.server.foo 0" to the powerdns.records table as SOA, without any refresh/retry etc. times after that zero so powerdns will tell default values for those in SOA-query.

My template:

Code:

[ZONE]
origin={DOMAIN}.
ns=ns1.server.foo.
mbox=email.server.foo.
refresh=7200
retry=540
expire=604800
minimum=86400
ttl=3600

[DNS_RECORDS]
A|{DOMAIN}.|127.1.2.3|0|3600
CNAME|www.{DOMAIN}.|some.server.foo.|0|3600
NS|{DOMAIN}.|ns1.server.foo.|0|3600
NS|{DOMAIN}.|ns2.server.foo.|0|3600
NS|{DOMAIN}.|ns3.server.foo.|0|3600
MX|{DOMAIN}.|mail.server.foo.|42|3600

It works like this too but it's really annoying to manually update the serial by adding some bogus A-record or tell that to some non-tech client to do.

Any ideas how to fix this?


All times are GMT +2. The time now is 10:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.