HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Bizarre problem solved! (http://www.howtoforge.com/forums/showthread.php?t=55930)

mike_p 26th January 2012 09:23

Bizarre problem solved!
 
I don't know what else to give as a title to this thread, but I thought it's worth posting.

A few weeks ago I started having strange problems with email accounts and DNS.

After a lot of work I realised that at some point overnight the /tmp directory was getting set with restrictive permissions, preventing certain services from using it.

As a temporary fix I set a cron job to reset the permissions.

Now I've found out what was doing the damage!

The new version of ISPConfig has a service to backup websites. It's run frm cron_daily.php. During the proces it checks the permissions of the backup folder and resets them if neccessary. Yes, you've guessed it, my backup directory was set to /tmp so ISPConfig was resetting permissions for the tmp directory.

Problem solved by setting the backup folder in ISPConfig (system:server configuration:server:...) to something other than /tmp!

Hope this solves problems for someone else!

till 26th January 2012 09:28

By the way, using /tmp as backup folder is not a good choice for another reason as well: PHP scripts from all sites have access to /tmp by default, so if site a.tld dumps its backup there then site b.tld might be able to load the backup of site a to get the mysql login details for site a. As conclusion, dont store sensitive data in /tmp :)

mike_p 26th January 2012 09:59

I note from the cron_daily script that ISPConfig uses the backup folder entry to determine whether to run the backup service. If the folder is empty, it won't run. Unfortunately the interface won't allow an empty field.
I don't want to run the backup service as I have an alternative sytem (using rsync from a remote server)

till 26th January 2012 11:10

The backup system will not run if you do not add any backup jobs as administrator. So if you dont want to use the backup system, just do nothing and dont change the default folder under System > interface config.


All times are GMT +2. The time now is 14:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.