HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   General (
-   -   Server Hacked? (

silenceti 17th January 2012 12:00

Server Hacked?

In my servers with ISPConfig, i've my postfix sending e-mails every second to unknow e-mail accounts!

What can i do?


till 17th January 2012 12:05

Most likely one of yor websites has a bug in a cms system or contact form so that spammers can use that to send spam trough your server. So its likely that the server itself is not hacked and you have just a vulnerable website.

To check if your server itself is hacked, use rkhunter:

rkhunter --update
rkhunter -c

silenceti 17th January 2012 12:46

Well, I don't see any "strange thing" with rkhunter...

That's a little weird!

I Start Postix and:

SMTP helo=<>
Jan 17 13:40:25 vp7 postfix/smtpd[21407]: NOQUEUE: reject: RCPT from n: 554 5.7.1 <>: Relay access denied; from=<> to=<> proto=SMTP helo=
Jan 17 13:40:25 vp7 postfix/smtpd[21396]: NOQUEUE: reject: RCPT from ]: 554 5.7.1 <>: Relay access denied; from=<> to=<> proto=SMTP helo=<>

I don't even know what e-mail accounts are these....

till 17th January 2012 13:00

Theseare the email accounts where the spam is send to.

See here for a method to find which of your websites is used to send the spam:

silenceti 17th January 2012 13:03

Hi till,
I don't think is a website, because i just have one, and it's a plataform, like interspire with haproxy!
I start haproxy, and mails are going out...

This is really weird!!!!

silenceti 17th January 2012 13:08


"Mail sent."

[root@ web]# cat /var/log/mail.form
[root@ web]#


till 17th January 2012 13:12

If you use php-fcgi, suphp or php-cgi, then you will have to edit the php.ini file /etc/php5/cgi/php.ini too. If you use custom php.ini settings for that website, you mighta hve to add the modifications in the custom php.ini field in ispconfig.

silenceti 17th January 2012 13:13

Can't find that file:

php -i | grep php.ini
Configuration File (php.ini) Path => /etc/php.ini

This is the correct one...I guess?

till 17th January 2012 13:23

If you use a centos or fedor system, then that should be the file. For centos or fedor you might have to adjust the sendmail path in the wrapper script.

silenceti 17th January 2012 13:28

OK, i can't find anything suspecious...but if I start haproxy mails still going out...!

All times are GMT +2. The time now is 06:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.