HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ssl certificate ispconfig 3 (http://www.howtoforge.com/forums/showthread.php?t=55666)

syduck 6th January 2012 23:31

ssl certificate ispconfig 3
 
Hi, i am trying to install a SSL certificate on my centos 5.5 ispconfig 3.

I generated a csr through ispconfig, got my certificate from the CA and pasted it in the SSL Certificate section, marked action 'save certificate' and pressed save.
Not sure what to do with the INTERMEDIATE certificate.

Everything looks like it worked, the vhost file looks fine, when i restart apache i get:
[warn] NameVirtualHost *:443 has no VirtualHosts
[warn] NameVirtualHost 99.99.99.99*:443 has no VirtualHosts (fake ip)
and when i try to browse to the https:// i get unable to connect.

any ideas why its not working? thanks

syduck 9th January 2012 06:22

fixed
 
The problem was mod_ssl was not installed, a yum install mod_ssl and a service httpd restart fixed it.

As for the intermediate certificate I downloaded it and placed it on the server and added this line to the vhost as per the CA instructions.

SSLCertificateChainFile /var/www/clients/client44/web60/ssl/intermediate.crt


All times are GMT +2. The time now is 22:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.