HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   server doesn't listen on UDP port 53 (http://www.howtoforge.com/forums/showthread.php?t=55662)

kmchen 6th January 2012 15:42

server doesn't listen on UDP port 53
 
zonecheck on a domain reports "server doesn't listen on UDP port 53"

When I look at :
Code:

Proto Recv-Q Send-Q Local Address          Foreign Address        State      PID/Program name
tcp        0      0 127.0.0.1:10024        0.0.0.0:*              LISTEN      3908/amavisd (maste
tcp        0      0 127.0.0.1:10025        0.0.0.0:*              LISTEN      3803/master
tcp        0      0 0.0.0.0:3306            0.0.0.0:*              LISTEN      2831/mysqld
tcp        0      0 0.0.0.0:110            0.0.0.0:*              LISTEN      894/pop3-login
tcp        0      0 0.0.0.0:143            0.0.0.0:*              LISTEN      895/imap-login
tcp        0      0 87.98.160.188:53        0.0.0.0:*              LISTEN      797/named
tcp        0      0 176.31.109.26:53        0.0.0.0:*              LISTEN      797/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*              LISTEN      797/named
tcp        0      0 0.0.0.0:21              0.0.0.0:*              LISTEN      3870/pure-ftpd (SER
tcp        0      0 0.0.0.0:22              0.0.0.0:*              LISTEN      3772/sshd
tcp        0      0 127.0.0.1:953          0.0.0.0:*              LISTEN      797/named
tcp        0      0 0.0.0.0:25              0.0.0.0:*              LISTEN      876/smtpd
tcp        0      0 0.0.0.0:993            0.0.0.0:*              LISTEN      895/imap-login
tcp        0      0 0.0.0.0:995            0.0.0.0:*              LISTEN      894/pop3-login
tcp6      0      0 :::8080                :::*                    LISTEN      624/apache2
tcp6      0      0 :::80                  :::*                    LISTEN      624/apache2
tcp6      0      0 :::8081                :::*                    LISTEN      624/apache2
tcp6      0      0 :::53                  :::*                    LISTEN      797/named
tcp6      0      0 :::21                  :::*                    LISTEN      3870/pure-ftpd (SER
tcp6      0      0 :::22                  :::*                    LISTEN      3772/sshd
tcp6      0      0 ::1:953                :::*                    LISTEN      797/named
tcp6      0      0 :::443                  :::*                    LISTEN      624/apache2

I see my server listens only on 3 ip adresses: real ip, ipfailover and lo
But in /etc/bind/named.conf.options:
Code:

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };
        listen-on { any; };
//      allow-recursion { 127.0.0.1; };

It seems to be configured to listen on any port. Where are defined the 3 ip limitations ?

falko 7th January 2012 11:33

What's the output of
Code:

netstat -uap
?

kmchen 9th January 2012 19:45

Here is the result of the command:
Quote:

root@ks392200:~# netstat -uap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 ks392200.kimsufi:domain *:* 4429/named
udp 0 0 ks392200.kimsufi:domain *:* 4429/named
udp 0 0 localhost.locald:domain *:* 4429/named
udp6 0 0 [::]:domain [::]:* 4429/named

falko 10th January 2012 17:13

named is listening on port 53 UDP, so I guess it's a firewall issue.


All times are GMT +2. The time now is 05:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.