HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig page only works internally (http://www.howtoforge.com/forums/showthread.php?t=55590)

djkoelkast 31st December 2011 16:39

ISPConfig page only works internally
 
The https://www.domain.tld:8080 page doesn't work for me, it's just doing nothing at all. The https://192.168.x.x:8080 however works just fine.
I did open up the correct ports on the router, but could it be a iptables issue or something like that?
Also my newly installed roundcube webmail works fine through http://192.168.x.x/webmail but doesn't on http://www.domain.tld/webmail (there it gives me a download called "webmail" which seems to be the index.php file itself, so it does not parse at all).

Any clues on what is going on here and how I can solve this?

djkoelkast 31st December 2011 16:43

I solved the 1st issue, it was my own mistake on IP addresses.
The webmail issue however still exists.

cbj4074 3rd January 2012 01:25

Quote:

Any clues on what is going on here and how I can solve this?
Yes. See my posts in this thread:

http://www.howtoforge.com/forums/showthread.php?t=55182

djkoelkast 3rd January 2012 01:40

Quote:

Originally Posted by cbj4074 (Post 270655)

I don't want it on webmail.domain.tld but on www.domain.tld/webmail, I do think there is a big difference.
Also the webmail is working on my full IP too: http://212.xxx.xxx.xxx/webmail but on none of my domains

This is /etc/apache2/sites-enabled/000-roundcube:

Code:

Alias /webmail /usr/share/roundcube

<Directory /usr/share/roundcube>
  Options Indexes FollowSymLinks
  AllowOverride None
  DirectoryIndex index.php
  Order Allow,Deny
  Allow from all
</Directory>
<Directory /usr/share/roundcube/*>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/config>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/temp>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/logs>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/skins>
  Allow from all
</Directory>
<Directory /usr/share/roundcube/bin>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/SQL>
  Deny from all
</Directory>
<Directory /usr/share/roundcube/program>
  Allow from all
</Directory>
<Directory /usr/share/roundcube/plugins>
  Allow from all
</Directory>


cbj4074 3rd January 2012 01:49

Quote:

I don't want it on webmail.domain.tld but on www.domain.tld/webmail, I do think there is a big difference.
I discuss using this method in the cited thread, too.

Quote:

Also the webmail is working on my full IP too: http://212.xxx.xxx.xxx/webmail but on none of my domains
This indicates that Roundcube is configured to work only with your "default" site.

Did you read the link to the "common pitfall" thread that I linked to in the aforementioned post? That thread is about SquirrelMail, but almost everything therein applies to Roundcube, too.

http://www.howtoforge.com/forums/sho...t=52042&page=4

Once you've read through that, if you still have issues, let us know.

djkoelkast 3rd January 2012 12:37

This fixed it, I edited the file /etc/apache2/sites-enabled/000-roundcube to:

Code:

Alias /webmail /usr/share/roundcube

<Location /webmail>
<IfModule suphp_module>
suPHP_Engine Off
AddHandler php5-script        .php
</IfModule>
php_admin_value open_basedir "/usr/share/roundcube"
</Location>

and then the rest there was.
Now it works fine. It might be the "dirty" way, but I think it's better than disabling suPHP all together.
Thanks for your help, I think more people come across this and now have a nice all in one topic solution.


All times are GMT +2. The time now is 20:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.