HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   PDC setup Please help (http://www.howtoforge.com/forums/showthread.php?t=5557)

Macros 16th July 2006 18:10

PDC setup Please help
 
Hi there I have followed the PDC for small business setup to the letter but no joy I cannot get my 2 other machines on the network to join the domain, not sure what I have done, let me tell you a little about my setup maybe that will shed some light. I have a netgear router, that all the machines are attached to wireless and hard wire, the default WORKGROUP created by the roter is NETGEAR so I named my domain NETGEAR thinking that all the machines could just join the same domain, when I try to join the domain on a windows machine I get the following:

Quote:

The domain name NETGEAR might be a NetBIOS domain name. If this is the case, verify that the domain name is properly registered with WINS.

If you are certain that the name is not a NetBIOS domain name, then the following information can help you troubleshoot your DNS configuration.

The following error occurred when DNS was queried for the service location (SRV) resource record used to locate a domain controller for domain NETGEAR:

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.NETGEAR

Common causes of this error include the following:

- The DNS SRV record is not registered in DNS.

- One or more of the following zones do not include delegation to its child zone:

NETGEAR
. (the root zone)

For information about correcting this problem, click Help
.

My smb.conf file looks like this
[global]
netbios name = SERVER1
username map = /etc/samba/smbusers
WINS Support - Tells the NMBD component of Samba to enable its WINS Server
wins support = yes
; wins server = w.x.y.z
name resolve order = hosts wins bcast
; interfaces = 127.0.0.0/8 eth0
; bind interfaces only = true
log file = /var/log/samba/log.%m
# Put a capping on the size of the log files (in Kb).
max log size = 1000
; syslog only = no
syslog = 0

panic action = /usr/share/samba/panic-action %d

# in the samba-doc package for details.
security = user

encrypt passwords = true

passdb backend = tdbsam

obey pam restrictions = yes

; guest account = nobody
;invalid users = root

unix password sync = yes

# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de>
for
# sending the correct chat script for the passwd program in Debian Sarge).
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:*
%n\n *password\supdated\ssuccessfully* .

; pam password change = no

domain logons = yes

; logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
; logon path = \\%N\%U\profile

logon drive = H:
logon script = scripts/logon.bat
logon path = \\server1\profile\%U
# Useradd scripts
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/usermod -G %g %u
add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
# # sync smb passwords woth linux passwords
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:*
%n\n .
passwd chat debug = yes
# set the loglevel
log level = 3
; logon home = \\%N\%U

; logon script = logon.cmd

# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

; load printers = yes

; printing = bsd
; printcap name = /etc/printcap

printing = cups
printcap name = cups

; printer admin = @lpadmin

; include = /home/samba/etc/smb.conf.%m

# SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY

; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

domain master = yes

idmap uid = 10000-20000
idmap gid = 10000-20000
template shell = /bin/bash

[homes]
comment = Home Directories
valid users = %s
read only = no
browseable = no

; valid users = %S

; writable = no

; create mask = 0600

; directory mask = 0700
Logons
[netlogon]
comment = Network logon service
path = /home/samba/netlogon
admin users = administrator
valid users = %u
read only = no
guest ok = yes
writable = no
share modes = no

[profiles]
comment = User profiles
path = /home/samba/profiles
valid users = %u
create mode = 0600
writable = yes
browsable = no
directory mask = 0700

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
guest ok = yes
create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[SHARED DOCS]
path = /home/Shared Docs
guest ok = yes
case sensitive = no
writable = yes
msdfs proxy = no
root@server:/etc/samba#

Thanks in advance any help is appreciated.

crudolphy 22nd July 2006 22:32

I believe you need to insert the following under the [global] section of your smb.conf

workgroup = NETGEAR

Then restart samba, make sure your windows clients are set to be members of the "NETGEAR" workgroup or join the "NETGEAR" domain.

Hope this helps.

Chuck Rudolphy

till 23rd July 2006 11:35

Please change:

netbios name = SERVER1

to:

netbios name = NETGEAR

and restart samba. Make sure that you disable wins in your netgear router.


All times are GMT +2. The time now is 12:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.