HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   forbidden error since last update (debian squeeze) (http://www.howtoforge.com/forums/showthread.php?t=55462)

dranach 20th December 2011 00:57

forbidden error since last update (debian squeeze)
 
Since my last update 2 days ago, I cannot acces my websites anymore. I get a 403 forbidden error. To what ailment is this the symptom? Anybody else have this problem?

I am running ispconfig 3.0.4.1 on debian squeeze.

Thanks in advance

chume 20th December 2011 03:03

I encountered the same error yesterday after upgrading to 3.0.41 and found out that the web folder in the /var/www folder is owned by root.root instead of the webx.clientx user.

Everything started working after the ownership of /var/www/domain.com/web is changed.

I hope this helps.

till 20th December 2011 09:22

Please ensure that the security level is set to high under system > server config > web.

dranach 20th December 2011 10:15

Quote:

Originally Posted by chume (Post 269942)
I encountered the same error yesterday after upgrading to 3.0.41 and found out that the web folder in the /var/www folder is owned by root.root instead of the webx.clientx user.

Everything started working after the ownership of /var/www/domain.com/web is changed.

I hope this helps.

Everything in /var/www/domain/web is set to webx.clientx, except for the stats-folder (owned by root). I cross-checked with another site, on another server, where the stats-folder is owned by root.root too.

I failed to mention that the upgrade concerned the Debian Squeeze distribution. Ispconfig already was 3.0.4.1

dranach 20th December 2011 10:17

Quote:

Originally Posted by till (Post 269953)
Please ensure that the security level is set to high under system > server config > web.

I checked, it is set to 'high'

till 20th December 2011 10:32

Take alook at the error.log of the wesbite and post the error message that you find there for the forbidden error.

dranach 20th December 2011 10:56

Problem is solved by putting back a complete image of the server. This is some kind of a brute force solution because it was becoming urgent. Consequently I still cannot tell what the underlying problem was..
I will come back if it manifests itself again.

In the meantime I have a problem with another website, where the page remains blank. I'll check first for a solution myself. If necessary I'll start a new thread for it.

Thank you all for your efforts, though.

Toni


All times are GMT +2. The time now is 21:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.