HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Debian 6 and ISPConfig 3 Problem with vhosts (http://www.howtoforge.com/forums/showthread.php?t=55440)

christospgr 17th December 2011 10:43

Debian 6 and ISPConfig 3 Problem with vhosts
 
Greetings,

Thank you for providing ISPConfig 3 it's been an amazing job.
I have followed the This guide to setup my server. My server is located at hetzner I have assigned to the server 2 IP's which work.

I have setuped the IP's at the /etc/network/interfaces. I add the Sites at the DNS module and then I add the sites at the Sites module.

My problem is that all the sites I have added are redirecting to one site and the vhosts seem that they are not working. I have checked one by one and the seem to be ok. Any suggestions?

Thank you in advance

till 17th December 2011 11:31

Ensure that you selected the ip address and not * in the website settings.

christospgr 17th December 2011 11:36

This is a vhost
Code:

<Directory /var/www/panagis.me>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost 88.198.57.147:80>
      DocumentRoot /var/www/panagis.me/web
 
    ServerName panagis.me
    ServerAdmin webmaster@test.me

    ErrorLog /var/log/ispconfig/httpd/panagis.me/error.log

And this is the default from site-available
Code:

<VirtualHost 88.198.57.147:80>
        ServerAdmin webmaster@localhost

DocumentRoot /var/www
        <Directory />

I am sure that is the IP selected it refuses to work.

till 17th December 2011 16:56

and you entered panagis.me in the bowser URL bar and not www.panagis.me? As you did not enable the auto subdomain www, you can only access the site with panagis.me.


All times are GMT +2. The time now is 00:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.