HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   wordpress MU and ISPconfig .htaccess isues (http://www.howtoforge.com/forums/showthread.php?t=5540)

palkat 15th July 2006 05:18

wordpress MU and ISPconfig .htaccess isues
 
Okay spent the day on this and here is the problem.
I install wordpress MU (multi user blogs) and configured it for users blogs to go in directories (IE: doamin.com/userblog) versus subdomains. either way i have the same issue though. that is when wordpress finishes its install it creates a .htaccess file in the web directory that then produces "403 forbidden" errors. if i remove the .htaccess the paths don't all work for the wordpress as it requires the .htaccess commands, so i copied the contents of the .htaccess file that wordpress created into the Apache Directeives box for the domain it is in and still does not work, get 403 errors. I then went and looked at the Vhosts_ispconfig.conf file to see what came of the .htaccess i put into the ispconfig directives and here is how it looks for the domain im working with:

Code:

######################################
# Vhost: www.homeschooldiary.com:80
######################################
#
#
<VirtualHost 192.168.1.200:80>
# RewriteEngine On # NOT SUPPORTED!
# RewriteBase / # NOT SUPPORTED!
#  # NOT SUPPORTED!
# Rewrite www.domain.com to domain.com
# RewriteCond %{HTTP_HOST} ^www\.(.*) # NOT SUPPORTED!
# RewriteRule ^(.*)      http://%1/$1 [R,L] # NOT SUPPORTED!
#  # NOT SUPPORTED!
#uploaded files
# RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L] # NOT SUPPORTED!
#  # NOT SUPPORTED!
# RewriteCond %{REQUEST_FILENAME} -f [OR] # NOT SUPPORTED!
# RewriteCond %{REQUEST_FILENAME} -d # NOT SUPPORTED!
# RewriteRule . - [L] # NOT SUPPORTED!
# RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L] # NOT SUPPORTED!
# RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L] # NOT SUPPORTED!
# RewriteRule . index.php [L] # NOT SUPPORTED!
#  # NOT SUPPORTED!
ServerName www.homeschooldiary.com:80
ServerAdmin webmaster@homeschooldiary.com
DocumentRoot /home/www/web17/web
ServerAlias homeschooldiary.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /home/www/web17/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web17/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ "/home/www/web17/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web17/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web17/user/$1/web/$3
</VirtualHost>
#

So needless to say looks like the ispconfig setup does not like these directives in the Apache Directive under ispconfig or as a striaght .htaccess file.

(NOTE: i was able to set this up perfectly on a server i have with dixiesys on a directadmin system no problems)

So is there a resolution to get this to work with ISPconfig? I know it needs the .htaccess directive to make this script funtion but how on ispconfig?

HELP!!! THanks!

TheRudy 15th July 2006 11:43

Did you install mod_rewrite module for apache? It looks like its missing by all that NOT SUPPORTED texts..

And do not edit VHosts... use .htaccess instead.. and please do check you have that module installed.

palkat 15th July 2006 17:04

Quote:

Originally Posted by TheRudy
Did you install mod_rewrite module for apache? It looks like its missing by all that NOT SUPPORTED texts..

And do not edit VHosts... use .htaccess instead.. and please do check you have that module installed.

THanks for the reply. So I ran info.php and looked for mod_rewrite and here is the only referance to it and it is under apache2handler

Code:

Loaded Modules:
core prefork http_core mod_so mod_access mod_actions mod_alias mod_auth
mod_auth_dbm mod_autoindex mod_cgi mod_dir mod_env mod_expires
mod_include mod_log_config mod_mime mod_negotiation mod_setenvif mod_ssl
mod_suexec mod_userdir mod_php5 mod_rewrite

Now correct me if im wrong but does that mean mod_rewrite is active. I thought so, but still get mod_rewrite error/no support from ISPconfig... I am still green to all this too. :D

So where should i go from here?

palkat 15th July 2006 18:41

close the topic...found the solution had to apply the correct options in the <directory /home/www/*/web>

All fixed.

till 18th October 2006 11:57

Just for reference, you will have to set the options directive in your httpd configuration file to the following value:

Quote:

Options +Includes +FollowSymlinks -Indexes


All times are GMT +2. The time now is 06:10.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.