HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   change takes too long to apply (http://www.howtoforge.com/forums/showthread.php?t=55397)

matiasCU 14th December 2011 00:33

change takes too long to apply
 
I have an installation of ISPConfig Version: 3.0.4.1 and have noticed that when I create a mail user from the panel, the change takes too long to apply, ie no mailbox quickly created in /var/vmail/domain.tld/user

Looking at the logs of ispconfig I see the following messages


13.12.2011-20:14 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.12.2011-20:14 - DEBUG - No Updated records found, starting only the core.
13.12.2011-20:14 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.12.2011-20:15 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.12.2011-20:15 - DEBUG - No Updated records found, starting only the core.
13.12.2011-20:16 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:17 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:18 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:19 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:20 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:21 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:22 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:23 - DEBUG - There is already an instance of server.php running. Exiting.
13.12.2011-20:24 - DEBUG - There is already an instance of server.php running. Exiting.

When I try to see the process server.php only see one running

ps aux| grep server.php
root 796 0.0 0.0 7544 848 pts/0 S+ 20:25 0:00 grep server.php
root 30704 0.7 0.1 178284 16368 ? S 20:15 0:04 /usr/bin/php -q /usr/local/ispconfig/server/server.php

I am also using glusterfs, but I don't think the problem is that since even before the update panel to the new version everything worked very fast.

Can someone help me with this?

Tks

falko 14th December 2011 18:59

What's the ouptut of
Code:

ls -la /usr/local/ispconfig/server/temp/
?

matiasCU 14th December 2011 21:07

Thank you for responding as always Falco,
I think you've identified the problem, I see a file _lock. This is not good right?


drwxr-s--- 2 ispconfig ispconfig 4096 Dec 14 16:30 .
drwxr-s--- 13 ispconfig ispconfig 4096 Aug 30 12:37 ..
-rw-r--r-- 1 root ispconfig 0 Dec 14 16:30 .ispconfig_lock
-rw------- 1 root ispconfig 227 Dec 14 16:59 rescue_module_serverconfig.ser.txt

Why should I do in this case?

Tks

matiasCU 14th December 2011 22:02

I did rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock and appears to be running all correctly now.

Tks Falco


All times are GMT +2. The time now is 23:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.