HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   how to setup external mail client to send mail (http://www.howtoforge.com/forums/showthread.php?t=55395)

karalitani 13th December 2011 20:53

how to setup external mail client to send mail
 
i setup a server with this tutorial:

The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]

then i installed roundcube instead of the squirrelmail

i can send and recieve mail with roundcube (webmail)

but when i try to setup a desktop email client like thunderbird,
i can only receive emails i cant send them.

i believe that i have tried using the submission port,
but that doesnt work wither,

any ideas?

thanks in advance.

falko 14th December 2011 18:53

Are there any errors in your mail log (in the /var/log/ directory)?

karalitani 15th December 2011 02:48

i figured it out
 
i had to un-comment the submission port
and add the port to the ispconfig firewall.

that enabled it.

i also came across another error after i got it working,
about the file-system when the email client connected.

i installed the gamin library

apt-get install gamin

then i restarted courier services:

find /etc/init.d/ | grep courier | while read line; do $line restart; done

and the error went away.

thanks for your quick reply falko.

pier56 31st December 2011 17:29

Hello,

The same problem happens after upgrading to squeeze, keeping ispconfig 3.0.4.1. I have a dedicated server OVH.

In /var/log/mail.log :
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: connect from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: disconnect from localhost.localdomain[127.0.0.1]

Thanks !

pier56 1st January 2012 18:32

Precisions :
  • it is possible to send emails to the server
  • it is possible to send mails by smtp server from webmail
  • it is only impossible to use smtp from thunderbird
And other problem (explained in another post) : now, I can't manage emails accounts by ispconfig.


Quote:

Originally Posted by pier56 (Post 270556)
Hello,

The same problem happens after upgrading to squeeze, keeping ispconfig 3.0.4.1. I have a dedicated server OVH.

In /var/log/mail.log :
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: connect from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: disconnect from localhost.localdomain[127.0.0.1]

Thanks !


cbj4074 3rd January 2012 01:22

Quote:

it is possible to send emails to the server
Okay, so Dovevot/Courier/whatever is working as intended.

Quote:

it is possible to send mails by smtp server from webmail
This makes sense, given that the connection is local (no firewalls in the way, etc.)

Quote:

it is only impossible to use smtp from thunderbird
Have you even tried taking the same step as karalitani? Try un-commenting the so-called "submission port" in your Postfix configuration and restarting the Postfix service.

If the port(s) is (are) already open, then try setting your SMTP port in your email client to 587 (plaintext or STARTTLS) or 465 (SSL).


All times are GMT +2. The time now is 12:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.